Deepstream failed to create 'sink_sub_bin_sink1'

When trying to build and use the Jetson Yolov3 example in deepstream 5.0, I get the following error message:

root@jetson-xavier:~/deepstream/sources/objectDetector_Yolo# …/…/bin/deepstream-app -c deepstream_app_config_yoloV3.txt

(deepstream-app:3579): GLib-GObject-CRITICAL **: 01:04:44.956: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed

(deepstream-app:3579): GLib-GObject-CRITICAL **: 01:04:44.957: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed
** ERROR: <create_render_bin:95>: Failed to create ‘sink_sub_bin_sink1’
** ERROR: <create_render_bin:172>: create_render_bin failed
** ERROR: <create_sink_bin:732>: create_sink_bin failed
** ERROR: <create_processing_instance:802>: create_processing_instance failed
** ERROR: <create_pipeline:1296>: create_pipeline failed
** ERROR: main:636: Failed to create pipeline
Quitting
App run failed

I have performed all of the steps listed in the yolov3 example:

  • downloaded yolov3 weights and cfg to: /opt/nvidia/deepstream/deepstream/sources/objectDetector_Yolo
  • didn’t install TensorRT because it’s already installed with Jetpack
  • changed sources/objectDetector_yolo/nvdsinfer_custom_impl_yolo/Makefile to
    • CUDA_VER=10.2

I am on the following platform:
**• Hardware Platform: Jetson Xavier AGX **
./bin/deepstream-app --version-all
deepstream-app version 5.0.0
DeepStreamSDK 5.0.0
CUDA Driver Version: 10.2
CUDA Runtime Version: 10.2
TensorRT Version: 7.1
cuDNN Version not available
libNVWarp360 Version: 2.0.1d3

Hi,

Could you clean the cache with below command and try it again?

$ rm ~/.cache/gstreamer-1.0/ -rf

Thanks.

Hi,

I tried that, no luck. Same error.

Solution found: I am using Yocto to build my platform, and I was missing
gstreamer1.0-plugins-nvvideosinks

from my image.

Good. Thanks for updating the status!