deepstream-test4 azure iot edge runtime setup failure

Hi,

I have tried to test the announced turn key integration with Azure IoT Hub/Edge,
but failed to setup by following the instructions in the README.

The problem is that moby-engine can not be installed as below.

$ sudo apt-get install moby-engine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  aufs-tools
The following NEW packages will be installed:
  aufs-tools moby-engine
0 upgraded, 2 newly installed, 0 to remove and 111 not upgraded.
Need to get 25.9 MB of archives.
After this operation, 127 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://packages.microsoft.com/ubuntu/18.04/multiarch/prod bionic/main arm64 moby-engine arm64 3.0.6 [25.8 MB]
Get:2 http://ports.ubuntu.com/ubuntu-ports bionic/universe arm64 aufs-tools arm64 1:4.9+20170918-1ubuntu1 [101 kB]
Fetched 25.9 MB in 3s (8,938 kB/s)                                      
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package aufs-tools.
(Reading database ... 133350 files and directories currently installed.)
Preparing to unpack .../aufs-tools_1%3a4.9+20170918-1ubuntu1_arm64.deb ...
Unpacking aufs-tools (1:4.9+20170918-1ubuntu1) ...
Selecting previously unselected package moby-engine.
Preparing to unpack .../moby-engine_3.0.6_arm64.deb ...
Unpacking moby-engine (3.0.6) ...
dpkg: error processing archive /var/cache/apt/archives/moby-engine_3.0.6_arm64.deb (--unpack):
 trying to overwrite '/usr/bin/docker-proxy', which is also in package docker.io 18.09.2-0ubuntu1~18.04.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/moby-engine_3.0.6_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I got the same result on Nano, TX2, and Xavier.

Is this something related to the NVIDIA container runtime?
Or should I ask in the Azure community?

Thanks!

Hi TakenoriSato,

I can’t answer where the problem is, but if that’s related with NVIDIA Container Runtime, The we start support it form JetPack 4.2.1, here is tutorial for your reference:
https://github.com/NVIDIA/nvidia-docker/wiki/NVIDIA-Container-Runtime-on-Jetson

The problem is docker.io is already installed, perhaps by the SDK manager.

So, I will try simply skipping this step, and move forward.

TakenoriSato i have the Jetson TX2. I want to connect this as an Azure IoT Edge device. The purpose is to collect the video of a room or a an small outside area and identify specific object there jst to get their x,y,z coordinate and store it somewhere even as the x,y,z changes. so i need to identify the object, remember it, and obtain its location in 3d space. So my first question is can i easily do this with NVidia Jetson TX2 rnning as an IoT Edge Device. my second question is what are the skills and what is the pipeline needed to do this? Which camera wold be best? Not break my budget. a stereoscopic camera? Matterport? which interface CSI? do i use microsofts machine learning models or do i need to built something directly onto the Deepstream SDK?

I can probably “cheat” and pt an easily identifiable sticker on the object. My questions are more how to get started with a Hello world.

I went to the Azure Iot Edge Marketplace and couldnt find the docker image.

Bam! https://github.com/toolboc/IntelligentEdgeHOL

Hi TakenoriSato,

I managed to overcome this problem. Encountered the same problem as you when I was testing deepstream-test4 on jetson nano. I did not know how to ‘skip this step’, and went to remove the existed install docker with:

sudo apt-get remove docker docker-engine docker.io containerd runc

Results:

Removing docker (1.5-1build1) …
Removing nvidia-docker2 (0.9.0~beta.1+docker18.09.2-1) …
Removing docker.io (18.09.2-0ubuntu1~18.04.1) …

before proceeding with the installation of moby-engine etc and was successful. Tried to reinstall docker, but was met with the error message:
trying to overwrite ‘/lib/systemd/system/docker.service’, which is also in package moby-engine 3.0.6
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

This probably indicates that moby-engine has docker package as well? Regardless, i am able to proceed. Still trying to figure out Azure IoT. Have not met with the repercussion of uninstall “nvidia-docker2” yet.

IoT edge will install its own Docker as moby engine. So you don’t have to install Docker on the device host.

@tommywu052 yes, it appears to be the case.

@tommywu052 @PallandoWicke actually i think its more like the IoT Edge install directions suggest you install moby-engine but you can have an existing docker installation. the problem with not installing nvidia-docker2 is that nvidia-docker2 seems to be a necessary wrapper for docker to be able to access the GPU.