Deinterlace problem (bug)?

Hi.

I’m using release

# R32 (release), REVISION: 2.3, GCID: 17644089, BOARD: t186ref, EABI: aarch64, DATE: Tue Nov 5 21:48:17 UTC 2019

Input video:

Stream #0:0[0x65]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p(tv, top first), 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 50 tbr, 90k tbn, 50 tbc

But some frames contain interlaced regions after transcoding, see attachment.

What could be the reasons for this behavior?

Please execute sudo jetson_clocks to see if can gain better result.

Done.
sudo jetson_clocks
sudo jetson_clocks --show
SOC family:tegra186 Machine:quill
Online CPUs: 0-5
CPU Cluster Switching: Disabled
cpu0: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c7=0
cpu1: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c6=0 c7=0
cpu2: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c6=0 c7=0
cpu3: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c7=0
cpu4: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c7=0
cpu5: Online=1 Governor=schedutil MinFreq=1420800 MaxFreq=1420800 CurrentFreq=1420800 IdleStates: C1=0 c7=0
GPU MinFreq=1134750000 MaxFreq=1134750000 CurrentFreq=1134750000
EMC MinFreq=40800000 MaxFreq=1600000000 CurrentFreq=1600000000 FreqOverride=1
Fan: speed=255
NV Power Mode: MAXP_CORE_ALL

Unfortunately we have same result. Nothing changed.

Hi,
It may be this known issue:


Please apply the patch for a try.

Thank you for patch.

But i’m not using gstreamer. My app not have crashes or memory leaks. My app based on MM API.
I found an old topic with a similar problem - Deinterlacing problem in TX2

In that thread, you suggested a patch - Deinterlacing problem in TX2

Maybe there is something similar for my release?

Hi,
The fix is for r28 release and cannot be applied to r32. Are you able to share steps so that we can reproduce the issue. Maybe a patch we can apply to 00_video_decode.

I’m attaching h264 (3-part zip archive) dumped from original stream. 00_video_decode decode this file successfuly and produced ~1Gb file.

./video_decode H264 --disable-rendering -o ~/vod/1920.raw ~/vod/1920i50.h264

I don’t know how to check or upload this file for you. Please try decode attachment and send me result.

I’m checking raw file with http://rawpixels.net/ service, i’m also attaching screenshot.

1920.h264-001.zip (4 MB) 1920.h264-002.zip (4 MB) 1920.h264-003.zip (3.8 MB)

Hi,
So the issue is not seen by decoding it through 00_video_decoder. Only happens in your application?

Hi.
The problem is reproduced with 00_video_decode. I’m attaching decoded file screenshot above.

Hi,
It looks expected if an object is moving fast. The hardware filter may not be able to handle the case when the object is moving too fast.

Hi.
It’s possible using yadif deinterlace engine for achieve better result? what alternatives can you suggest?

Hi,
We don’t have experience in using software deinterlacing engine. Would need other users to share suggestion.