Dell PowerEdge R730 + nVidia Grid K1 issues on bootup


We are having some issues with a nVidia Grid K1 GPU in a Dell PowerEdge R730 chassis. Once the GPU is installed in the chassis, the PowerEdge server cannot boot past the BIOS. It stops at "initializing USB, PCIe and Video. The console error reads: PST-0208 System BIOS has halted. We do have another Grid K1 GPU that we tried and still the same result. The more interesting thing is that we tried a Grid K2 GPU and it boots up no problem.

The Dell R730 server BIOS has been updated to version 1.5.4.

Memory Mapped I/O above 4GB is enabled.

Any help would be greatly appreciated.

Can you contact Dell. Since the K2 starts correctly it may be an issue with the way the BIOS handles the additional GPU’s in the K1.

Hi Jason,

We had Dell come in and replace both riser cards, cables and the motherboard with no change in the Dell PowerEdge R730.
As a side note, I found out that the Grid K1 cards we received were sent to us right as they were released. Is there a possibility that the firmware is is out of date and no compatible with the Dell Servers? At the moment we do not have any more Grid K1’s to confirm this.

I forgot to mention we got these NVidia Grid K1 cards directly from NVidia as part of the developer program.

The last firmware update was released Nov 2013, it’s been on Dell’s site since Apr 2014.

If you got the cards through the partner program, it would be worth getting in touch with your Nvidia contact.

We had the exact same issue. The resolution was to upgrade the Grid VBIOS firmware as suggested by Jason. Latest firmware is here:

Thanks Josh! Helpful info!