Nvlddmkm.sys Blue Screen Error - Windows 2012 R2 Datacenter

Hello.
I just bought a Dell PowerEdge R720 with the following specs:
192 GB RAM, 2 Perc RAID controllers (1 SATA 6- 5 TB, 1 SSD - 3 TB)
1 Matrox built-in video card
1 NVidia Grid K1 vGPU Card

I followed this procedure:

-Insert Dell Open Management disc and perform Windows 2012 Datacenter R2 x64 with Dell built-in drivers.
-Run Dell Bios Update for R720 (v2.2.3) latest version.
-Run Chipset Update and recommended drivers from support.dell.com (according to my Service Tag)
-Apply Windows Updates and reboot.

The system is OK until now, but the problems begin in the next step:
-after reboot, install NVidia Grid vGPU driver 332.83 (http://www.nvidia.com/download/driverResults.aspx/74598/en-us)
after installing this video driver, I reboot the system and when Windows logo appears and waiting dots starts spinning the screen goes black for a couple of seconds and then I receive a blue screen:
Page_Fault_In_NonPaged_Area (Nvlddmkm.sys)
Then the system collects some data and enters an infinite loop of reboots.

If I start the server in Safe Mode and remove the driver everything just works fine again.
I also tried with driver 333.11 for Grid K1 and receive the same error.

Does anyone know if this is a known issue or if there is any newer or stable driver for this card?
According to NVidia support, this card is supported on Windows 2012 R2.
I also tried the TDR registry key values for detection delay but no success! (http://www.instructables.com/id/How-to-Fix-the-Nvlddmkm-Error/)

Any help will be appreciated!
Thanks in advance.

Thanks Ronnyman,

I hope you are using Xenserver 6.2 SP1 with latest patch updated. If no, Please follow this procedure to update the latest fix http://support.citrix.com/article/CTX140417

If you are still able to reproduce this issue with latest hot fix, Please confirm the host driver and which vGPU you are trying to map with VM.

NOTE:For enabling vGPU, ensure that GPUs are mapped below the 4G boundary by disabling your server’s SBIOS option that controls 64-bit memory-mapped I/O support. This option may be labeled “Enable >4G Decode” or “Enable 64-bit MMIO”.

I forgot to mention I’m running Hyper-V Manager under Windows 2012 Server R2 Datacenter as Virtualization Technology.

I already disabled the 4G option in BIOS but no success.

I receive the same error after reboot.

Thanks Ronnyman for the confirmation.

Please share the msinfo32 logs and confirm the K1 vGPU card VBIOS information.

Also, you installed 332.83 in VM… Right? So after installing the driver you are rebooting the VM and you are seeing BSOD… Right?

Please correct me if my understanding is wrong.

thank you very much for your help.
I sent minidump errors to Dell support and think the vGPU Card is not working properly.
they are sending a new replacement card tomorrow.
I think this will fix the problem.
I ll let you know anyway.

I think there is some confusion here.

If you are running Server 2012R2 with HyperV then you should not be using 332.83 driver. That driver is specifically for our Citrix based vGPU technology. Unfortunately Microsoft have chosen to refer to their Remotefx technology as vGPU which is very confusing and possibly the reason that you chose the 332.83 driver version.

Please try installing the latest server2012R2 NVIDIA driver which is 340.52 on your system and see if this helps. You can find it here:- http://www.nvidia.com/download/driverResults.aspx/77038/en-us

Mike