/dev/sdb1 : clean, 640729/122388848… and Keyboard is not working

/dev/sdb1 : clean, 640729/122388848 files… blocks And keyboard is not active, keyboard doesn’t work

Ubuntu 16.04
NVIDIA GPU 1080ti

I cannot open the computer. /dev/sdb1 : clean message stays there. Cntrl+Alt+f1 or Cntrl+Alt+f7 is not working because keyboard is not working.

It is a dual boot. I installed windows 10. I installed ubuntu to ssd. Before start, there are options : Ubuntu Windows etc. Then keyboard is working in this screen. But when I choose ubuntu, and enter, Then : /dev/sdb1 message stays on screen and keyboard is not working. And not start.

So how can I fix ?

Did you already install the nvidia driver?

Yes, it was working first.

But after for a while, it started not to run. Hanging “/dev/sdb1 : clean” on black screen.

I tried to fix via grub with root prompt:

$ sudo apt update then receiving error : Could not resolve ‘developer.download.nvidia.com’ Could not resolve ‘tr.archive.ubuntu.com

$ sudo apt upgrade Could not resolve ‘tr.archive.ubuntu.com

(I use dual boot : Windows and Ubuntu.)

It was running, but it started not to run after 04.10.2018 gpu Windows driver updates. I cannot open ubuntu boot. Black screen frozen with “/dev/sdb1 : clean”.

Is it temporary issue because of gpu driver updates or should I fix something ?

If you can get to the prompt, try uninstalling the nvidia driver

sudo apt-get purge nvidia*

so your system falls back to intel/nouveau. Then see if you can reinstall the driver from ppa:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Yes, I removed nvidia driver.
And installed again.
It is running now. Solved.

But I need to disables automatic NVIDIA driver updates/cuda updates/ubuntu updates/Windows updates,etc.

How can I do it ?

I use Ubuntu 16.04 and Windows as dual boot. Same NVIDIA GPU.
So I think I need to disable all to make stable system.

Windows updates should not have any effect on the drivers in the Ubuntu partition. That was most likely just a coincidence.
If this happens again, just report it as a bug to the ubuntu bugzilla, always keep an eye on what gets updated.

In my case it was due to gdm3 not running. So I restarted it using these commands:

sudo service gdm3 status (to ckeck status)
sudo service gdm3 start

It doesn’t matter if you are using lightgdm, gdm or gdm. To find out which one you are using try sudo service --status-all | grep gdm

I have the same problem upon turning on Ubuntu 18.04 with Nvidia 2070 Super. While I turn off the Ubuntu 18.04 and turn on it again. It goes back to the normal state. It is just like a bug for the Ubuntu 18.04 system with Nvidia Driver.

It is necessary to address that nvidia-430 ppa is not accepted by RTX 2070 super. Nvidia has closed the opportunities of nvidia-430 ppa installation. The system automatically gives the Nvidia-440 ppa for installation.

I have the following installation steps

1. Add the Nvidia ppa repo

$ sudo add-apt-repository ppa:graphics-drivers/ppa

2. Update

$ sudo apt-get update

3. Install Nvidia driver

$ sudo apt install nvidia-driver-440

4. Reboot Ubuntu 18.04

$ sudo reboot

5. Check the Driver

$ nvidia-smi

It has still has the problem sometimes.

Please indicate how to solve it completely.

Thanks in advance,

Notes:

While I met the problem with RTX 2060 several month ago, I installed nvidia-driver-430 ppa, it solve the issue. However, while I had RTX 2070 Super this week, I could not be allowed to install nvidia-driver-430 ppa, Therefore, the error occurs again. And it seems that I have no better way to solve it this time. nvidia-driver-440 ppa has a problem with Ubuntu 18.04 but it is forced by Nvidia.

Mike

The ppa is not managed by nvidia but the Ubuntu driver team.
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).