Device tree set with FDT ignored


I have a weird problem. My carrier board is a waveshare one that uses eMMC instead of the SD card. I followed the process described here in order to move everything to the SD card. All good and working fine.

However, when trying to apply the device tree changes required for the TC358743, the boot-up process defaults to the original DTS file and ignores my FDT entry. There’s no mention of an error or anything.

0.420699] DTS File Name: /dvs/git/dirty/git-master_linux/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0002-p3449-0000-b00.dts
Mar 30 09:26:59 jetson-nano kernel: [ 0.420707] DTB Build time: Apr 20 2022 14:28:59


DEFAULT primary
MENU TITLE L4T boot options
LABEL primary
MENU LABEL primary kernel
LINUX /boot/Image
FDT /boot/tegra210-p3448-0002-p3449-0000-b00.dtb
INITRD /boot/initrd
APPEND ${cbootargs} quiet root=/dev/mmcblk1p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1

PS: I modified the DTB file to include both the changes required for the TC358743 and the ones described in the guide for using the SD card.

I think the issue here is the extlinux.conf still reads from emmc. Not sdcard.

1 Like

How would I be able to confirm this is indeed what’s happening?

please dump the serial console log.

or do some test, add some modification to your extlinux.conf and check if dmesg shows it or not.

For example, remove the “quiet” from extlinux.conf and see if dmesg still has quiet or not.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.