Difference in setting the maxn mode through flash.sh and the nvpmodel command

Hi,
I’ve noticed that there are two ways to set Orin to maxn mode. The first way is by using the flash.sh script with the jetson-agx-orin-devkit-maxn parameter during the image flashing process. The second way involves using the flash.sh script with the jetson-agx-orin-devkit parameter during the image flashing, followed by configuring the system with the nvpmodel command while the system is running.

What are the differences between these two approaches? Which method do you recommend more?

Hi gdwang,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in use?

I would suggest pre-select it before flash.
You can refer to Preselect Power Mode - #3 by KevinFFF for details.

1 Like

HI KevinFFF,

Thanks for reply. I’m using custom board for AGX Orin, Jetpack 6.0GA.
I noticed that the BPFDTB_FILE is different in using parameter ‘jetson-agx-orin-devkit-maxn’ and ‘jetson-agx-orin-devkit’ while flashing, so I guess there might be some difference for the bpmp in normal and maxN mode.

Will it affect the performance if I use the pre-select methord with the ‘jetson-agx-orin-devkit’ flashing parameter ?

The jetson-agx-orin-devkit-maxn conf is the true MAXN config file.

The mode 0 from jetson-agx-orin-devkit has slightly lower power than this.

2 Likes

Hi WayneWWW,

How about the CPU/GPU/DLA performance of these two MAXN modes?
Will the ‘jetson-agx-orin-devkit-maxn’ mode be better?

Yes, it would be much better. But no matter what situation, maxN should not be in use for production.

Hi WayneWWW,

What are the possible disadvantages of maxN in use for production?
Are there any cases to illustrate this?
Thanks!

maxN may push the power to the limit of each module. If over the spec, then throttling would happen and you may see lower performance.

You should control your product to run specific usecase under your requirement, but not always rely on maxN mode.

For example, if 30W can achieve what you need, then you should not always use maxN.

Got it. Thanks a lot!