Difficulty pushing 165 FPS in many applications using Arch Linux, 370.28, a GTX 1080, and a PG279Q G-Sync monitor


I’ve been having some difficulty with this for several months now. Basically, several applications (Chromium, Firefox, Thunderbird, Steam, etc) default to rendering at 60 FPS, even when the display is set to 165 Hz. I have tried using different desktop environments, running with various compositors, and forcing 165 FPS rendering where possible, but most applications still run into problems.

I’m not sure where to start, so I’ll dump some of the most relevant links. First and foremost, I began reaching out to others to try to troubleshoot this issue on reddit:


Chromium was the first application that I noticed this happening in, and it’s by far the most frustrating. There is a bug report over at the Chromium tracker, but it’s been largely ignored.


I later found this bit of information indicating that TwinView can report incorrect refresh rates to applications:


And I also used Xlib to get my display information in a small C++ program. It reports the width and height as 2560x1440 properly, but reports the refresh rate as 50, even though XRandR and my monitor’s “FPS” counter both properly report 165.

When I use vsynctester.com in both Chromium and Firefox, it’s locked at 60. In Firefox, I can change layout.frame_rate to another value such as 0 for uncapped or 165 to meet my monitor’s refresh rate, but this results in problems with uneven frame pacing.

G-Sync also seems to cause issues in games/applications that do push 165 FPS properly, particularly if vsync is enabled. In Rocket League, for example, I can still get screen tearing with G-Sync enabled, even though the monitor’s FPS counter fluctuates as would be expected. Additionally, if playing in fullscreen mode, G-Sync + in-game vsync causes the game to frequently “freeze”. Consistent cursor movement will keep it rendering, but when the cursor stops moving it will start rendering in the single-digit FPS range. This problem also occurs in Chromium if I set it to fullscreen mode in i3. These issues occur both with and without a compositor running.

I am currently running i3wm with Compton, and I need to tell Compton to run at 165 Hz as well, otherwise that too defaults to 60. :\

Very much at wit’s end here. I’ve thrown about everything I can at these issues, and absolutely nothing is fixing them. 60 FPS on a 165 Hz display feels horrendous, and I would very much like to get everything running at native refresh rate.

nvidia-bug-report.log.gz (139 KB)