Frame rate cap

I hope I got to the right forum and that my inability to find a matching thread or anything on Google was not just due to my, well… inability.

I’d like to limit my GTX660 to a maximum frame rate. For simple applications (that is, certain games), I get like 3500(!) frames per second and the fan does make a good job of it. I’d prefer to have say 120 fps (like my monitor can show) and have less work for the fan. And less noise. And Watts. And degrees. (I think the Windows drivers are doing something like that automatically, don’t they?)

This is called VSync or Vertical Synchronization. The graphics card will send one complete image to the monitor every time it does a refresh. Enable it in your graphics option of your game.

On second read, my question was the wrong one. Or at least I should have elaborated.

I know about VSync and I did try it, but to no avail. That’s why I was looking for another possbility.

The game itself does not have a VSync option. I tried to enable “Sync to VBlank” generally (via the nvidia-settings application) as well as by an application profile setting GLSyncToVblank to true and a rule using the process name as well as one that “always applies”. The file $HOME/.nv/nvidia-application-profile-globals-rc mentioned in http://us.download.nvidia.com/XFree86/Linux-x86/337.19/README/profiles.html does not exist, so the usage of these settings should be enabled by default. Anything I might be doing wrong or having forgotten here?

Independent of the above, is there something in Windows that avoids frame rates way to high by default without having VSync enabled?

I don’t know if nvidia-settings can apply VSync if the game is not true fullscreen instead of just fullscreen windowed (which means it’s just a very big window that is still composited by your desktop compositor). Most games only allow fullscreen windowed, because it is easier for the game developer and plays better together with different window managers and desktop environments. Otherwise if the game is true fullscreen and you change the resolution and the game crashes you’ll be stuck with the same resolution, when it crashes to desktop.

Which game is it? Is it based on the Unity engine? They seem to ignore vsync settings on Linux.

I had it with the not-so-well-known “J.U.L.I.A. - Among the Stars”, based on the Wintermute engine (and AFAIR with others, but I didn’t find any among my installed games).

This guy says he has it with Civilization V: http://steamcommunity.com/app/221410/discussions/0/618458030682131912/