Disabling serial port on Jetson Nano Micro USB interface

I am currently using the Jetson Nano Development Kit (4GB), but we are working to building our own custom carrier board for the Jetson Nano SOM.

On the dev kit, there is a serial port running on the Micro-USB interface (the USB interface used for recovery mode). On our custom hardware, this USB interface will be configured for host mode and used for USB devices like webcams. I don’t want the serial port enabled on this interface but am having trouble disabling it.

I have found that the serial port is tied to the “/dev/ttyGS0” device. Can anyone provide any details on which driver creates this device and how I might go about disabling it?

hello mfransham ,

please follow below steps to disable it.

  1. Remove “earlyprintk=uart8250-32bit,0x70006000” from kernel cmdline
  2. Change ODMDATA to 0x14000, you’ll need to re-flash the target to apply the settings.
  3. Remove console=ttyS0 in kernel cmdline.

Hi @JerryChang. I appreciate the quick reply.

I am wondering whether we are referring to different serial consoles though. There is the main debug console on the 12-pin header of the dev kit (same header that has the force recovery pins). I want to keep that one. It is the serial console that runs on the micro-USB interface that I want to disable. Could you clarify which serial port your instructions apply to?

As another experiment since my post, I rebuilt the kernel with “CONFIG_USB_GADGET” not set and this seemed to provide the desired results. I no longer see the “/dev/ttyGS0” device and there doesn’t appear to be a serial interface running on the micro-USB interface anymore. Do you know if this is an appropriate solution for what I’m hoping to do?

hello mfransham,

there’s no serial console that runs on the micro-USB interface on Jetson Nano,
please see-also Jetson Nano Product Design Guide for chapter-11.3 UART.

Perhaps I am misusing the term “serial console”. Maybe UART is the better term?

What I am referring to is that I can plug a Micro-USB to USBA cable between the Jetson Nano dev kit and my laptop and through Putty connect to the Jetson Nano as a COM port. I get a Linux login prompt and can login to the Jetson over this interface. It connects to /dev/ttyGS0. This is the functionality I’m trying to disable for our custom hardware.

hello mfransham,

there’s /etc/systemd/system/nv-l4t-usb-device-mode.service to configure USB flashing port for device mode.
please have a try to disable this service, thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.