Jetson Nano Production Module [eMMC] Port Issue

I have a production module Jetson Nano Production Module. I started the flash process using the SDK manager and connected Keyboard, Mouse, and Monitor before flashing ( I tried connecting them after the flash process too.) The Jetson successfully boots up and the monitor attached shows the ubuntu installation GUI (screenshot attached) but Jetson does not recognize the keyboard and mouse (they are not even receiving power). It seems like the ports are suddenly not working. So I cannot interact with the OS to complete the installation.

I cannot perform a headless setup since I am booting from an eMMC instead of the SD card and requires to have the image already flashed to the card.

I have also tried using Serial Console (minicom and screen) but does not receive any data in the terminal and is black.

Please provide Help on any of the above methods.


Please directly re-flash it again and see if the usb port has power or not.

The USB Port has no power.

If you still want to check something, you can use this script I shared long time ago to bypass the initial configuration.

After booting into device, use the ethernet to dump the dmesg to me.

Or you can directly RMA this board and get a new one.

Respected Sir,

This method does not seem to work. The sdk manager still asks for Target device pwd and username, the display of the jetson is still not recognizing the usb ports and gets stuck at system configuration.

Is there any way I can boot from a USB and change the installation partition to the emmc storage?

Or any other method i can try?

If you use the method, you should not use sdkmanager. You should directly use to flash.

If you never used before, please check our quick start guide from download center.

Used the command along with the script
sudo ./ jetson-nano-emmc mmcblk0p1

Still getting the System Config page on boot up.
I have tried using the minicom serial console but nothing is displayed in the serial console. The port connection has been checked.
Any fixes / alternative methods i can try?

It sounds like you didn’t run the script correctly. Where and how did you use this script? Please note that if you run this script, you shall never let sdkmanager run again to overwrite the existing files.

Also, please also share your flash log to make sure you really let the board get correctly flashed.

I used SDK manager to download the OS and its dependencies. After doing that I downloaded the script into
after which extracted it and ran sudo ./ -u <usr_name> -p password
then finally ran the flash command

Are you sure the flash command working fine? It sounds like you are new to using, so I want to confirm it again.

Yes i am fairly new to this. After running the flash command. I get the successfully flashed msg on the terminal

What I can suggest now is you can follow this page to use the serial console from uart instead of the usb one. This serial console setup is very common when we are dealing with boot problem. If your script really sets the user account correctly, this serial console will serve as a ubuntu terminal and ask your user account and pwd. Otherwise, it will just stuck and no prompt.

Actually, I think your board has high possibility that requires to RMA. The behavior sounds like the usb port has broken. Thus, whether you need to follow this page and dump the uart log depends on you. Even after we see the log, we may still need to ask you to do RMA if this is really hardware problem.

Could you please verify the following command for flashing Jetson Nano Production [eMMC] Module
sudo ./ jetson-nano-emmc mmcblk0p1

If it tells you the flash is successful and you can see the desktop back from recovery mode, then the flash is correct.

The other board config will not be able to let emmc board boot correctly.

One more thing to check, your devkit carrier board is the B01 one but not A02 one, right?