DLI class RIVA server error problem

Hello, I am taking your DLI classes and I am a student who is learning artificial intelligence. I am taking one of the nvidia DLI courses, Building Conversational AI Applications.
I was going to do an assessment now,

_InactiveRpcError: <_InactiveRpcError of RPC that terminated with: status = StatusCode.UNAVAILABLE details = “failed to connect to all addresses; last error: UNKNOWN: ipv4: Failed to connect to remote host: Connection refused” debug_error_string = “UNKNOWN:failed to connect to all addresses; last error: UNKNOWN: ipv4: Failed to connect to remote host: Connection refused {grpc_status:14, created_time:“2023-10-19T08:19:11.89053107+00:00”}” >
You received these error messages. I don’t know that I should press that stop last week (October 9, 10th 2023) and I would like to ask if it’s because I pressed the access desk button or if it’s a different problem. I’m inquiring because I wrote all the correct answers correctly, but I came up with an error message that will proceed.

‘dli-support@nvidia.com’ I sent an inquiry email to this email address.

Now, I can’t learn because I get these messages every time I do this.

So please help me. I beg you.

Hello @eternallegion,

This looks like an issue for the DLI team. I have forwarded this issue to the engineers for a look.

Thanks for your patience.


Thank you for your reply. I would like to express my appreciation and respect for your work. Thank you.

1 Like

Hello @eternallegion,
I’m from the DLI team and hope I can help you. I’ll start with some general guidance:

  • When you stop the DLI instance (or it times out), you’ll need to restart the instance. You can only run one DLI instance at a time. Data will not persist into the new instance.
  • If/when you start over, you’ll need to once again enter your NGC API key in notebook #3 (003_intro_NGC_Setup.ipynb). Without the NGC setup, Riva won’t work correctly.
  • To test if everything is working, you could work through notebook #8 (008_Full_Pipeline.ipynb). If that is working correctly, then completing the assessment (assessment.ipynb) should also be possible.

If the tips above don’t help, please let me know your procedure exactly, and which notebook and section you experienced your errors in.

As for the one I sent yesterday, it’s not for DLI, so I sent it to this account (an account with DLI Cress registered).I just checked this out. This is my fault. I’m sorry, but the error side has not been resolved yet. I would appreciate it if you could check the updated post for this account.
This error has not been resolved yet. What happened in the beginning was almost the last time. Yesterday, as you said, I executed the note after number 8, but the same error as that capture screen occurred in note 11.
Because of that error, I re-executed it 8 times from logout, but I always got an error over there. So I checked note 11, and the same error occurred.

I am studying hard with Jetson and DLI that you will make. I really appreciate this part.

I hope all your business and research work goes well. I’m rooting for you as a novice user, developer, and maker.

error n.zip (489.1 KB)
Screenshot of page with error. I’ve also created a location.
A number of errors occurred in Note 11. I didn’t see the result until the end because there was an error in the middle.

Hi @enternallegion,
Thank you for attaching your errors. Let me recap my understanding of the problem (please advise if this is not what is happening):

  1. You completed Notebook 3 to set up your authorization for NGC using your API key in both Step 1 and Step 2.
  2. Notebook 8 worked for you without error and you shut down both Riva (the last cell) and shut down the notebook kernel as instructed at the end of the notebook.
  3. Your issues began with Notebook 11, for which you have attached errors from 11.1, 11.2, and 11.3; the assessment also had an error, for which you have attached a capture.

Looking at your first error in 11.1: “Error: failed to fetch https://helm.ngc.nviida.com/… 401 Unauthorized” This indicates a problem with your NGC key and/or associated email address. These are added in the 2nd cell of notebook 11. Please check to make sure these were added correctly and the cells executed from the beginning of the notebook. Failure at 11.1 would also cause failures in 11.2 and later in the notebook. Please note, however, that a failure on 11.3 is expected. The notebook explains the port choices in this cell and a few following.

Notebook 11 requires a bit of patience. Please read the instructions and explanations carefully as you may be expected to re-execute some of them and update values to get the expected responses.

Regarding the assessment error in the final conversation cell. I can’t tell what the root cause of the error is because what I can see looks okay; I suspect something is wrong in a previous cell as the error indicates that the input is empty. I suggest you carefully check the earlier “check your work” lines for inconsistencies and run the assessment grader to see if the feedback can point you to a solution.

I hope this helps unblock you!

1 Like

I appreciate your help. Thanks to you, I’ve solved what I had to suffer for two weeks.
I heartily thank you.


Hello, How did you fix the problem? I’m dealing with a similar issue and could use some help.