DNN library is not found

Hi,
trying to run object detection inference using tensorflow 2.12 on jetson orin nano 8gb , cuda 11.4 cudnn 8.6 jetpack 5.1.2 , got the following error:

Traceback (most recent call last):
  File "utils/tf2_model/object_detection_cam.py", line 84, in <module>
    detections = detect_fn(input_tensor)
  File "/usr/local/lib/python3.8/dist-packages/tensorflow/python/saved_model/load.py", line 740, in _call_attribute
    return instance.__call__(*args, **kwargs)
  File "/usr/local/lib/python3.8/dist-packages/tensorflow/python/util/traceback_utils.py", line 153, in error_handler
    raise e.with_traceback(filtered_tb) from None
  File "/usr/local/lib/python3.8/dist-packages/tensorflow/python/eager/execute.py", line 52, in quick_execute
    tensors = pywrap_tfe.TFE_Py_Execute(ctx._handle, device_name, op_name,
tensorflow.python.framework.errors_impl.UnimplementedError: Graph execution error:

2 root error(s) found.
  (0) UNIMPLEMENTED:  DNN library is not found.
	 [[{{node ssd_mobile_net_v2keras_feature_extractor/functional_1/Conv1/Conv2D}}]]
	 [[StatefulPartitionedCall/Postprocessor/BatchMultiClassNonMaxSuppression/MultiClassNonMaxSuppression/Reshape_28/_70]]
  (1) UNIMPLEMENTED:  DNN library is not found.
	 [[{{node ssd_mobile_net_v2keras_feature_extractor/functional_1/Conv1/Conv2D}}]]
0 successful operations.
0 derived errors ignored. [Op:__inference_restored_function_body_52267]

trying to load model : SSD MobileNet v2 320x320 from : models/research/object_detection/g3doc/tf2_detection_zoo.md at master · tensorflow/models · GitHub

more info :

>>> tf.__version__
'2.12.0'
>>> print("Num GPUs Available: ", len(tf.config.list_physical_devices('GPU')))
Num GPUs Available:  1
>>> tf.test.is_gpu_available()
WARNING:tensorflow:From <stdin>:1: is_gpu_available (from tensorflow.python.framework.test_util) is deprecated and will be removed in a future version.
Instructions for updating:
Use `tf.config.list_physical_devices('GPU')` instead.
True
>>> tf.test.is_built_with_cuda()
True

any idea how to solve this issue ?
Thanks in advance

Hi,

Have you tried to run the same app on other platforms that have GPU, ex desktop environment?
If not, please give it a try. The experiment helps to check if this issue is Jetson-specific.

Thanks.

@AastaLLL yes it worked on desktop environment ubunutu 20.04 tensorflow 2.12 , cuda 11.8, cudnn9.0

FYI, I tried cuda 11.8 and cudnn9.0 on the jetson still not working

FYI Inference worked on CPU

@e.saleh149
Can you please attach the relevant code that generates the exception for me to try and replicate?

Hi @guyda
i followed this tutorial :
https://tensorflow-object-detection-api-tutorial.readthedocs.io/en/latest/auto_examples/plot_object_detection_saved_model.html

Hi,

Would you mind sharing how you set up the environment as well?
We try to reproduce this internally but get stuck by TFOD → tensorflow_text → bazel → jdk → java.lang.NoClassDefFoundError: Could not initialize class com.google.devtools.build.lib.unsafe.StringUnsafe error.

Thanks.