Do not manage to activate HDMI on a laptop with NVIDIA GeForce RTX 2060

I am trying to use the HDMI output on my laptop (MSI GL63 8SE) with Debian 10, the problem that it’s not detecting my monitor in HDMI port. I have two VGA compatible controllers, which is Intel UHD Graphics 630 and NVIDIA GeForce RTX 2060.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1)

After some searching, I found out this should be some settings related to Nvidia optimus technology.

https://unix.stackexchange.com/questions/321151/do-not-manage-to-activate-hdmi-on-a-laptop-that-has-optimus-bumblebee

According to the answer, I installed bumblebee by the following instruction

sudo apt-get install bumblebee-nvidia primus libgl1-nvidia-glx

After that, I created a 20-intel.conf file in the Xorg configuration directory (/usr/share/X11/xorg.conf.d)

Section "Device"
    Identifier "intelgpu0"
    Driver "intel"
    Option "VirtualHeads" "2"
EndSection

And modified /etc/bumblebee/xorg.conf.nvidia as below

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "true"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    Option "ProbeAllGpus" "false"
    Option "NoLogo" "true"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "DiscreteNVidia"
EndSection

However, with previous configuration and starting intel-virtual-output, I could not output the signal to my external monitor by HDMI.

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 5 outputs: 3 associated providers: 0 name:Intel

Any suggestions? Thank you!
nvidia-bug-report.log.gz (1.1 MB)

I’d rather suggest to use PRIME rather than bumblebee, the primus bridge also doesn’t work anymore with drivers >418. See this for a quick howto:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
Please uninstall bumblebee beforehand.