HP notebook - Nvidia 840m + intel - Mint (ubuntu) 20.04 and 460 drivers - don't work

Hi all.
I have readed an tested several ways to make this driver work, without success.

I am using Mint, with lightdm. My kernel is 5.4.70.

Removed all drivers, tried to install by the downloaded file from Nvidia site, it doesn’t work.

Do the same, but this time, installing by PPA and ubuntu-drivers autoinstall. It have installed the driver automatically, but doesn’t work.

Primary problem: nvidia-smi error. don’t connect to driver.

Secondary problem: Nvidia icon appears on my dashboard, but always inform “using vesa”. Even if i choose Nvidia, it keeps in mesa.

Followed problem: Nvidia X server settings only shows what card i want to use, but even selected Nvidia, it doesn’t work.

I don’t care if I have to use an older driver… if it works, is fine to me .

I am on my way to attach the log from bugreport. (Edit: attached.)

Thanks in advance.nvidia-bug-report.log.gz (472.0 KB)


NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.


lspci -k | grep -EA3 ‘VGA|3D|Display’
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
DeviceName: Intel(R) Graphics GT2
Subsystem: Hewlett-Packard Company Haswell-ULT Integrated Graphics Controller
Kernel driver in use: i915

0a:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev ff)
DeviceName: NVIDIA GeForce GT 840M
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

You seem to have bbswitch/bumblebee installed which turns off the nvidia gpu, please uninstall.
Furthermore, something is always requerying the monitors, do you have some plugin installed in DE?

Generix, thanks for the fast reply.

I am connected also with HDMI . Maybe it is the request?

Just removed bumblebee. Sorry, I have tried thousands things before ask for help.

I don’t have installed any plugins, AFAIK. But how to see it?

Rebooting, soon i came back to say if it works.

Thanks again.

:O:O:O it Worked. You are great.

So, remembering:

Remove all drivers, all stuff about nvidia.

Install driver PPA, automatically. I used sudo ubuntu-drivers autoinstall.

Install some libraries (libvulkan, libc6-dev)

Uninstall bumblebee.

Be happy :D

Thanks again. problem solved.