Docker_dli_run Error reponse from daemon

I’m using a jetson nano 2 gb and I tried to run the ./docker_dli_run.sh. 1 day ago I got any problems but since I trunned on today to execute it with the following command:

echo "sudo docker run --runtime nvidia -it --rm --network host \
    --volume ~/nvdli-data:/nvdli-nano/data \
    --device /dev/video0 \
    nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.4.4" > docker_dli_run.sh

I get Denied Permission issue that gets solved with:

chmod +x docker_dli_run.sh

now, it still not running when I execute :

./docker_dli_run.sh

Each time, I’m getting :

docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused "process_linux.go:449: container init caused \"process_linux.go:432: running prestart hook 0 caused \\\"error running hook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-cli --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --compat32 --graphics --utility --video --display --pid=6884 /var/lib/docker/overlay2/dd8323a59ce054f3d8dca1ee77973773b92a2be247af38170720d0efcf1884aa/merged]\\\\nnvidia-container-cli: mount error: file creation failed: /var/lib/docker/overlay2/dd8323a59ce054f3d8dca1ee77973773b92a2be247af38170720d0efcf1884aa/merged/usr/lib/aarch64-linux-gnu/libnvidia-fatbinaryloader.so.440.18: file exists\\\\n\\\"\"": unknown.

Hi @Benj_Matth, you can get this error when you are running a different version of JetPack-L4T than the container was built against. Can you check your L4T version with cat /etc/nv_tegra_release?

For example, if you are running L4T R32.5.0, change your script to use nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.5.0. If you are using L4T R32.5.1, also use the R32.5.0 container.

Hi, I’m running in R32.5.1

# R32 (release), REVISION: 5.1

however, I get the following error:

Unable to find image 'nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.5.0' locally

Hi @Benj_Matth, can you do a sudo docker pull nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.5.0? If not, is your Jetson connected to the internet?

Hi, when I’m connected to the internet, I’m getting long downloading time then everything is right.
image
But I tough, I didn’t need to use it only when I’m connected to the internet

After you have downloaded the docker container, I believe you should not need internet connection anymore.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.