Docker login failed with -u -p parameters

As mentioned in Installation Using DRIVE OS Docker Containers,
sudo docker login -u="${YOUR_USERNAME}" -p "${YOUR_API_KEY}"
command failed, but this works:
docker login and then input user name & password, then login successfully.

The long password has copied to clipboard and used to input, so both user name & passwork should be ok.

I got this issue about several weeks ago, since logging in without -u/-p works, I just ignore it.
But today when I trying it again by following above official document, this issue fired again. I aslo tried removing all " in command, but got same error result.

So please comfirm -u -p parameters works with NGC. Thanks!

Dear @Keelung,
We are fixing the documentation issue. Please Follow the steps at Set Up Docker and NVIDIA GPU Cloud Access for docker access.

Hi @SivaRamaKrishnaNV ,
Thanks for you info. There is another doc bug in

This is one command and should be put into one block but two. Or users have to copy 2 times and combine them in one.

Nice catch. We will fix it. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.