Does Deepstream 5.0 work on Jetson Nano 2GB?

When I run

/opt/nvidia/deepstream/deepstream-5.0/bin$ ./deepstream-app -c …/samples/configs/deepstream-app/source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt

I get warnings like this and the video window doesn’t open

WARNING from sink_sub_bin_sink1: A lot of buffers are being dropped.
Debug info: gstbasesink.c(2902): gst_base_sink_is_too_late (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin1/GstNvOverlaySink-nvoverlaysink:sink_sub_bin_sink1:
There may be a timestamping problem, or this computer is too slow

It’s a warning, you can ignore this, the buffer is arriving late, not at expected time, that’s why you got the warning. about can not open the window, where did you run the sample? through remote login like putty or through desktop?

I ran it on VNC. I am going to try connecting it directly to a monitor now.

It should be fine you run through vnc, but you may give a try directly through monitor, btw, are you using type 2 eglsink?

It works directly through monitor. I am not sure if I am using eglsink. I might be since when I try the same configuration on X2Go Client I get “No EGL display”.

It uses all of the 2GB memory and a low memory warning pops up. How can I reduce the number of input streams to possibly reduce memory footprint?

There is also an issue with the desktop mode with directly connecting to the monitor. Mouse is out of sync with desktop coordinates which makes it very hard to use.

in the source* group in config file, there num-sources property you can set, to lower number, you also can use config file samples/configs/deepstream-app/source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt which have optimization for nano.