DOOM 3 BFG Vulkan renderer Running on nvidia jetson nano

These days of quarantine at home I have had time to test the new render of vulkan development the DOOM 3 BFG game https://github.com/RobertBeckebans/RBDOOM-3-BFG

I did a few tests above and didn’t have much trouble getting it to work it’s more performance is better than you might expect at 4K native resolution it works at ~20 fps or 15fps rate when there is intense lighting and shadows with many enemies on screen.

If you want fps close to 60fps, you should go to 1080p resolutions, it works in the environment of 45-60fps

I said Why not Squeeze the potential of nvidia jetson nano :)

How compile
git clone https://github.com/mrcmunir/RBDOOM-3-BFG
and execute the script in the neo folder
./cmake-linux-nvidia-jetson-vulkan-release.sh
You Will needed apt-get install cmake libsdl2-dev libopenal-dev libvulkan-dev (if not installed)

2 Likes

Thanks for the info _Diablo.

Is the 45-60 FPS at 1080P with jetson_clocks enabled?

Regards,
Chris.

Yes with sudo jetson_clocks activated should be the recommended thing, it gets a bit more stable during increased game usage in my experience at maximum fps peaks without vsync several noticeable.
Also would recommend Ventilation to the device in my tests goes up to 70-80 degrees in prolonged use if not good fan on it.
The minor framerate only happens in some cinematic scenes with the game engine or certain zombies appear throwing fires in these effect will litte down fps.
Regards
Mrc.

Is there any more steps needed? I get this error when trying to run it:

----- Initializing Vulkan driver -----
Creating Vulkan Instance...
Sys_Error: Error while creating Vulkan surface: VK_KHR_xlib_surface extension is not enabled in the Vulkan instance.

When checking vulkan extensions then I can see it is supported:

vulkaninfo | grep xlib
VK_KHR_xlib_surface                 : extension revision  6

Are you using Wayland? This extension seems X11 mandatory.

1 Like

I’m using X11. Dug in the code a bit and have to apply attached patch to get it up and running.

0001-Add-surface-extensions-manually.patch.txt (967 Bytes)

1 Like

I’m glad to know that you have fixed it
In my case it works without applying the patch
Anyway I have detected that of resolutions does not work very stable and compatibility and can scale badly in some resolutions or monitors if you’re running in Unity instean Ubuntu
Unity does weird things with rescaling that if you relogin with Ubuntu mode working fine in full screen.

1 Like

I’m using MATE instead of gnome so I guess that’s why I ran into the issue. Anyways I guess anyone on X11 will have to apply that patch.

Noticed resolution handling is a bit unstable too although was primarily testing how stable the OC for GPU is (looks like 1.15 GHz is the best I could get without system crashing). On 1440p I get roughly playable FPS (perhaps the GPU memory needs a bump here), 1080p is playable (AA etc. has to stay off). Overall I have to say it handles the game pretty well!

Noticed the CPU count isn’t detected properly from /proc/cpuinfo: 0001-Properly-detect-CPU-cores-on-jetson-nano.patch.txt (2.7 KB)

Posted the OC patch here (I am using a fan, and 5V 8A power supply): Overclocking Jetson Nano's CPU and GPU

1 Like

For detected cores count properly it’s known issue not merge yet .

and some segment fault when exit will be fixed by

And out of curiosity What power supply do you use 5v 8A and what type of fan that . I will may be interested in for future testing with the Overclock.

I’ve had this one lying around: https://www.amazon.com/gp/product/B078RZBL8X/ref=ppx_yo_dt_b_asin_title_o07_s00?ie=UTF8&psc=1 and using fan from this case (running my system from SSD): https://www.amazon.com/CMC-TECH-Enclosure-Development-Developer/dp/B082FSJPRM/ref=sr_1_3?dchild=1&keywords=CMC+TECH&qid=1592454085&sr=8-3

Note though that the developer guide says that maximum continuous input current is 4.4 A (at 5V), giving 22 W maximum input power. Haven’t done any concrete measurements but would say that typical 5V 6A power supply should be good as well.