Low performance in DOOM Eternal

Hello,
The game performance is very slow. There is a topik on GitHub where you can read all NVIDIA users have low peroformance ~15-25 FPS no matter the video settings.

In the mean time the game runs perfectly well on AMD and users are reporting 100+ FPS.

I’m with 1080 Ti and I experience the same problem with low FPS. I tried the latest vulkan drivers 440.66.03 and the stable one 440.64. Tried Flipping on/off, different OpenGL performance settings, different powermizer settings, compositor on/off, different resolutions, spoofing AMD card, enable/disable nvapi to no avail.

Here’s my nvidia-bug-report.log:

Arch Linux
Processor: Intel 9900K
Vulkan 1.2.135

2 Likes

I have the same performance problems.
in-game screenshot: https://steamcommunity.com/sharedfiles/filedetails/?id=2031013729
nvidia-log file: https://drive.google.com/open?id=1PnH_iCde_67XEUb5Hhfo0x1PJy7wUsUB
Vulkan 1.2.135
Geforce 1070

Operating System: Manjaro Linux
Nvidia-driver: 440.66.03
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Kernel Version: 5.5.8-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-7600K CPU @ 3.80GHz
Memory: 23,4 GiB of RAM

1 Like

Confirming performance issues on 1080Ti.

Vulkan 1.2.135

Operating System: Arch Linux-x86_64
Nvidia-driver: 440.64
Kernel Version: 5.5.10-arch1-1
OS Type: 64-bit
Processors: Intel Core i5-4690K @ 4x 4GHz
Memory: 15964MiB

nvidia-bug-report.loggz (378.1 KB)

2 Likes

One of the thousands posts on the Web:

Getting a lot of comments about Nvidia card users having issues. I’m sorry all, but it looks like nVidia people are going to have to wait for the fix. Nvidia users are second class citizens in Linux because of the proprietary drivers it uses. If you are a serious Linux user trade it in and grab an AMD card as the performance and compatibility is lightyears ahead of Nvidia. That isn’t to discount that Nvidia is still the king of Windows and Streaming setups.

Can we get some attention? An answer or something? Do you like this NVIDIA hate wave?

I can also confirm the same performance issues mentioned above.

Vulkan 1.2.135
Geforce GTX 1070
Operating System: Arch Linux
Nvidia-driver: 440.66.03
Kernel Version: 5.6.0-rc6-1-tkg-pds
OS Type: 64-bit
Processors: Intel® Core™ i7-6700K CPU @ 4.00GHz × 8
Memory: 15.6 GiB

I’ve tried a number of different kernels and proton versions, as well as driver version 440.64, and seem to always get the same result (if I can get into the game at all.)

I’d be happy to provide any additional info that might be of benefit to anyone willing to look into this.
Thank you!

1 Like

I’m having bad performance in this game too with my GTX 1060 6GB on Manjaro.

What I noticed by monitoring my RAM and VRAM ingame:
The game currently seems to use system memory instead of vram. This seems to be the problem (or one of them?) for the low FPS.
You can try it yourself:

  • monitor system ram and gpu vram usage when playing the game (for example with a hud or on another display)
  • change graphics settings to low -> watch the values
  • change graphics settings to ultra (or higher) -> watch the values changing

You may see, like on my system, that vram usage didn’t change much, but system memory filled up a lot.
Vram does not fill up over 2 GB much, even on highest settings for my card while the game says it would need much more vram, not only 2 GB. This is because this all landed in ram instead of vram I guess.

1 Like

I’d like to confirm the same problem on my system.

  • Vulkan 1.2.131
  • GeForce GTX 1080 Ti via ROG XG Station 2 (eGPU, Thunderbolt)
  • Operating System: Fedora 31 Silverblue x86_64
  • Steam version: Native beta (non-Flatpak)
  • Kernel: Linux 5.5.10
  • CPU: Intel® Core™ i7-8650U CPU @ 1.90GHz × 8
  • Memory: 23.2 GiB
  • nVidia driver version: 440.64

I’m getting about 24FPS max with a resolution of 1280x720 on low overall quality when I can normally play most games on high to ultra settings with decent FPS.

I can confirm the poor performance.

  • Geforce GTX 1070
  • Kubuntu 18.04
  • Intel core i5 7600k
  • Nvidia driver 440.64
  • Vulkan 1.1.126

I am getting between 10 to 20 fps on 1080p with the lowest graphics settings.

Sounds exactly like my experience. nvidia-settings reports dedicated memory usage at 900MB after loading into a game whereas in DOOM 2016 it’s like 2.7GB.

  • Ubuntu 20.04
  • RTX 2070S
  • driver 440.64 OR 440.66.03
  • vulkan 1.1.119 OR 1.2.135

One thing I did notice playing the game was that in the hell maps there are some real “low fps zones” where the fps drops to about 15 even if it was 100 just 1 step away in the same room.

Can also confirm the same issue. Game dumps everything to system memory, having 13 GB of RAM usage in total (on Ultra-Nightmare settings). VRAM usage is really low for a game like this. nvidia-smi shows less than 1GB of VRAM allocation. Game detects graphics card and Vulkan version just fine.

Specs:

  • AMD Ryzen 5 3600 3.95 GHZ
  • NVIDIA RTX 2070 (Driver: 440.66.04)
  • Vulkan version: 1.2.135
  • 32 GB GSKILL 3600 MHZ
  • Manjaro Linux 5.4.27-1

Hi! I’d like to confirm all problems that people above have stated.
Specs:

  • Intel Core i5 4670k
  • Nvidia GTX 980
  • Vulkan 1.2.135
  • 8 Gb DDR3@1600
  • KDE Neon, kernel 4.20

The game works, but framerate is very inconsistent and the mentioned vram issue is present.

Can also confirm the issue. The framerate goes well past playable 30 FPS to 19-20 FPS on any settings possible.

  • Arch Linux
  • Intel Core i7 8750H
  • Nvidia GTX 1060
  • Vulkan 1.2.135
  • Driver 440.66.03
  • 16 Gb DDR4@2666
  • Awesome WM
  • kernel 5.5.10-arch1-1

Did anyone try with driver 430.50 or lower? 430.64 got changed to use system memory in out of VMEM situations, maybe that is buggy? Needs an older kernel, though.

Just tried it.

The Vulkan version is 1.1.114, which is too old and doesn’t let it launch.

Ok, so no dice. Thanks for trying.

We’re looking into it.

9 Likes

Finaly some good news. Thank you!

I wonder if solving this might also solve the Wreckfest performance issues? Although in this case D:E uses vulkan natively while Wreckfest uses DX11.

Please do, Vulkan needs some love so that the game could run flawlessly :D

Hi aplattner, thank you so much for listening to us. I’m not sure whether it’s useful to you guys, but someone found out that the nVidia Linux drivers don’t seem to utilize VRAM correctly while playing the game, so everything goes to system RAM, instead: https://github.com/ValveSoftware/Proton/issues/3654#issuecomment-606952082