Downgrade Deepstream 5.0 to Deepstream 4.0

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Xavier
• DeepStream Version 5.0/4.0
• JetPack Version (valid for Jetson only) 4.2
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)

I have a Xavier, previously running Deepstream 4.0 application. When I tried to launch Deepstream 5.0 samples, I ran install.sh in deepstream-5.0, it seems this changed lots of underlying packages. Launching DS5.0 failed, so I decided to go back to DS4.0, yet noticed DS4.0 application cannot run any more.

Considering this might be caused by running DS5.0 install.sh, I ran DS5.0 uninstall.sh, then ran DS4.0 install.sh, yet the DS4.0 application still failed to run. The error is as below.

$ deepstream-test5-app -c configs/cur_conf.txt

(deepstream-test5-app:7621): GStreamer-WARNING **: 20:50:38.268: Failed to load plugin ‘/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_multistream.so’: /usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_multistream.so: undefined symbol: gst_nvquery_is_ntp_sync

** ERROR: <create_multi_source_bin:682>: Failed to create element ‘src_bin_muxer’

** ERROR: <create_multi_source_bin:745>: create_multi_source_bin failed

** ERROR: <create_pipeline:1045>: create_pipeline failed

** ERROR: main:1404: Failed to create pipeline

Quitting

App run failed

Anyone has any idea where is wrong, and what is the normal procedure to restore DS4.0 environment?

Hi bridge,

To have DeepStream SDK 5.0 work on Xavier, please upgrade your BSP by JetPack 4.4.
It can’t work well with JetPack 4.2.

@kayccc, thanks for reply, I knew that, the problem is upgrading from 4.2 to 4.4 needs flashing, no OTA. This is not possible for me since the device is not in my hand.

Fortunately I figured out a way to restore DS4.0. Basically follow steps below:

  1. uninstall.sh DS5.0
  2. install.sh DS4.0
  3. rm ~/.cache/gstreamer-1.0/registry.aarch64.bin
  4. unset DISPLAY for some application
1 Like