Deepstream 4.0 or 5.0

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU)**T4
• DeepStream Version4.0 or 5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version5.1.5 or 7
• NVIDIA GPU Driver Version (valid for GPU only) nvidia-smi: NVIDIA-SMI 450.36.06 Driver Version: 450.36.06

Hi,
I have a query, based on my understanding for Deepstream SDK 5.0, TensorRT 7 is used right. So can you comment whether it is best to use Deepstream SDK 4.0 or 5.0 in terms of reliability, features and support given from NVIDIA. Based on my understanding 5.0 is not as stable as 4.0. Kindly correct me if I am wrong.

Just my opinion, but I would consider starting with 5.0, just to avoid the upgrades you will need to make when moving from 4.0 to 5.0… not just the updates to Jetpack and Deepstream, but updates to your application as there are breaking changes in 5.0.

Regards,
Robert.

1 Like

Hi @rjhowell44 ,
Thanks for the info.
Regards,
Abraham