DRIVE AGX ORIN Developer kit not able to fully install

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[*] Linux

Hardware Platform
[*] DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version
[*] other

Host Machine Version
[*] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Hello We have the DRIVE AGX Orin Developer Kit. I have on numerous occasions flashed the DRIVE OS 6.0.6 on SDK Manager and even tried to install DRIVE OS via Docker Containers with DRIVE OS

I had some Flash errors in the beginning but they were resolved and managed to get successful installs and the OS would boot up however on booting up I noticed there was nothing about accepting EULA or even setting up SSH profile. I using the guide on this link:

I am at the section: Finalize DRIVE AGX Orin System Setup. However I am not able to go forward.

I tried to enable ssh however it says ssh.service not found

I have connected an Ethernet cable however when I go to the settings section on Network… it says “Oops, something has gone wrong, Please contact your software vendor”

Overall the ubuntu on Drive agx orin looks very minimalistic. I don’t think everything has been properly installed.

I have attached some images of the ubuntu screens Drive Agx orin

So issues I would like help is.

-Sorting out the SSH profile after accepting EULA agreements
-Is there meant to be more apps installed on DRIVE OS compared to the image shown with the programs currently been installed?
-Why is the Network section showing an error under Settings

Thank you.

  • The EULA typically appears on the first boot after a fresh installation. However, without clearing the persistent data, the EULA might not show up again even after reflashing.
  • I don’t really compare it to my setup but yes, DRIVE OS is a minimal installation.
  • Please refer to Network Manager does not exist in DRIVE OS installation.

Thank you for replying back

  • I have ticked the option to clear the persistent data during flashing it again. However still the EULA did not show up.

  • I have went into the link you provided for the Network Manager. Completed the " Configuring Interfaces" section as shown in the image below

Not sure if it solved that issue.

-Also just to double check, Do I need to the “Rebuilding the Filesystem from ubuntu-base and Local Mirror” Section as well?

-What about enabling ssh?

I understand you tried clearing persistent data during flashing. Please note from the recent release, flashing via SDK Manager is no longer supported. Instead, follow the ‘Install DRIVE OS Linux Docker Containers from NGC’ guide. Use the ‘–clean’ option as shown below:

# ./ --clean /dev/ttyACM1 p3710

For the network issue, it’s better to start a new topic linked to this one for better tracking and assistance.

No problem I will create new post with the network issues.

I re-flashed using the command: “./ --clean /dev/ttyACM1 p3710” It has flashed successfully as shown in the image below:

However the display is not showing at all. You seen the display used to work before with previous screenshots.

what would cause this issue? and how do I fix this?


Please confirm if you resolved the EULA and SSH issues after resetting the persistent partition. Also, were your previous screenshots from the version? If so, could you identify any differences between the previous flashing/setup and the current one?

No the EULA and SSH issues is still not resolved as when I re-flashed using command: ./ --clean /dev/ttyACM1 p3710 - (with persistent partition) it booted up with no display… On my previously reply I showed a screenshot on my host computer to show you the details on how I flashed it to the target device. I have no display therefore I am not able to see EULA and no able to set up SSH issues.

With sdkmanager I was able to run 6.0.6 version but again no EULA and no SSH. Hence why I went for the Docker approach, however with Docker I pulled the sdk build file of version

Please visit the ‘Finalize DRIVE AGX Orin System Setup page’ to understand the setup process. Then, connect your development kit by executing the following command to activate it:

sudo minicom -w -D /dev/ttyACM0

This should help you with the EULA and SSH setup.

Thanks Vick that worked. After I connected to minicom using that command - it popped up with EULA agreement. Note for others, you will need to use keyboard keys like Tab key, Arrow keys to navigate it through.

The display now turns on, and I was able to agree EULA terms and enabled SSH profile.

The only other thing I want to ask is when I logged in, it says “This system has been minimized by removing packages and content that are not required on a system that users do not log into”

as shown in this image:

Do I need to unminimize?


Great to hear you’ve successfully accessed the EULA and set up the SSH profile. As for the system displaying a message about being minimized, it’s more of a general Ubuntu feature and not Nvidia-specific. You might find solutions by searching online, considering it’s not directly related to Nvidia configurations. Let’s mark this particular issue as resolved here, and in case you encounter more concerns, let’s create a new topic for each, making it easier to address and keep things organized.

That’s fine thanks for letting me know. You may close this topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.