Drive px2 time sync guide-issue

I followed the instruction to sync the time, but when I proceed this step there is error.

nvidia@tegra-ubuntu:/home/nvidia/drive-t186ref-linux/samples/nvavb/daemons$ sudo ./ptp4l -f ./gPTP.cfg -p /dev/ptp0 -i eth0.200 -s -m -D -l 7

selected /dev/ptp0 as PTP clock
ioctl SIOCGIFHWADDR fialed: No such device
failed to generate a clock identity

Dear jieyng,

Please help to check the instruction again.

I could run the command w/o any error. Thanks.
nvidia@tegra-ubuntu:~/drive-t186ref-linux/samples/nvavb/daemons$ sudo ./ptp4l -f ./gPTP.cfg -p /dev/ptp0 -i eth0.200 -s -m -D -l 7
ptp4l[1114342.592]: selected /dev/ptp0 as PTP clock
ptp4l[1114342.593]: PI servo: sync interval 1.000 kp 0.700 ki 0.300000

Hi Steve,
I observed the eth0 instead of eth0.200. I found from other topic you posted, is it correct to use eth0? I attached pictures, what does the delay timeout mean? Also Aurix forget his time on every reboot.

sudo ./ptp4l -f./gPTP.cfg -p /dev/ptp0 -i eth0 -s -m -D -l 7
ptp4l[2003.965]: selected /dev/ptp0 as PTP clock
ptp4l[2003.966]: PI servo: sync interval 1.000 kp 0.700 ki 0.300000
ptp4l[2003.966]: port 1: get_ts_info not supported
ptp4l[2003.992]: port 1: INITIALIZING to LISTENING on INITIALIZE
ptp4l[2003.992]: port 0: INITIALIZING to LISTENING on INITIALIZE
ptp4l[2004.042]: port 1: setting asCapable
ptp4l[2004.442]: port 1: announce timeout
ptp4l[2004.442]: selected best master clock 48d35d.fffe.0000f1
ptp4l[2004.492]: port 1: delay timeout
ptp4l[2004.992]: port 1: delay timeout
ptp4l[2005.492]: port 1: delay timeout
ptp4l[2005.992]: port 1: delay timeout
ptp4l[2006.492]: port 1: delay timeout

Hi jieyng,

Have you managed to resolve this problem or it’s still an issue?