Driver 470.63.01: nvidia-modeset high CPU load, cannot detect EDID and turns the screen off

Hello everyone,
after having upgraded the driver to version 470.63.01 (actually, version 470.63.01-3 downloaded from rpmfusion) it has become quite impossible to use my Linux box.
It seems the problem is nvidia-modeset which is continuously running with a truly high CPU consumption (it actually takes 100% of the assigned CPU core) and after somewhile it turns the screen off.
The screen turns back on after several seconds (that is, when the CPU load drops) and after sometime (from very few seconds to very few minutes) it turns the screen off again and this goes on over and over, making it impossible to use the computer at all.
Every time the screen is turned off, I get this message in the system log:

nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device Samsung SA300/SA350 (DVI-D-0)

I can however confirm the EDID is perfectly readable from the monitor by using system tools and the monitor works perfectly when connected to a different computer.
I am trying to fix this since many days now, unfortunately with no avail, including disabling EDID options in X and providing a custom EDID file, which has however been of no help at all to fix this truly and very annoying bug.

For your information, I use Fedora 34 and the NVidia driver is from rpmfusion. As for my graphic card, it is a 4Gb GeForce GTX 1050 Ti, working perfectly and smoothly until I upgraded to driver 470.63.01 and with the very same SW/HW configuration.

Any idea how to fix this or whether it is a bug specific to this driver?

Thank you.

Kindest regards.

1 Like

This driver version is a nightmare! It is impossible to proficiently use Linux as it keeps on turning the screen off to black and turning it back on after some random time, repeating this TRULY annoying bug all day long and with a very high frequency.
I see no one replied to my message but I saw other users are experiencing similar bugs with their machines. I do not want to switch to nouveau but I am afraid this is something I will do before I have a total nerve breakout!
I tried everything I could, by tweaking both the kernel and Xorg, to no avail. I sincerely hope and wish a new and stable driver to be released very soon. 470.63.01 is a nightmare to work with!

Just a quick update to this very annoying and overwhelming nasty bug.
I upgraded my system to Fedora 35 which has now driver version 495.44. I hoped this new driver would fix this truly nerve breaking issue but, to my total disappointment, the black screen bug is still there.
And it exactly happens in the conditions I explained above. So far, although I am trying from time to time to understand the cause and fix this, I could not find anything useful to improve or fix this truly nasty condition. And I wished someone could give some help here.

Did you check with another cable? Any converters involved? When the nvidia-modeset module is going crazy, this usually means it has a hard time keeping the connection to the monitor alive.

Hello there and thank you for your reply.
One of my earliest attempt to fix this annoying bug was to provide the X server a custom EDID file and this prevented nvidia-modeset to ask this information to the monitor. It did not help that much as the driver kept on blanking the screen from time to time, and it still does that.
I also tried to change the cable but it did not help. When I provided the custom EDID file to X server, I did not see anymore the EDID warning in my system log and, as a matter of fact, nvidia-modeset is not consuming all that CPU time anymore.
This bug appeared the very moment I upgraded to driver 470.63.01 and stayed there from that moment on, including the other releases up to 495.44.
As I can see in the forum, it seems there are many who complain about this bug and I also tried some of the suggestions I found in other threads, unfortunately to no avail.

Thank you again for your reply and help.

Ubuntu 20.04, GT 720 Graphics card,
I encounterd almost same probelm with the latest (nvidia-modeset high CPU load).
After downgrade the driver to , it’s better now.

Please share nvidia bug report and repro steps so that we can try to replicate similar issue locally.

Ubuntu 20.04,
GT 720 Graphics card
CPU: AMD Ryzen 2600,
window manager is lightdm

  1. Ctrl+Alt+F1 to enter into text mode.
  2. in terminal, $ sudo service lightdm stop
  3. $ sudo bash (the latest driver)
    follow the prompt to install the driver, and reboot.
    after login in, Ctrl+Alt+F1 to enter text mode again, you can notice that the screen is blink as @dexbob mentioned. it seems that the driver turns screen on/off at interval 1 second

in terminal,
$ top shows that the nvidia-modeset periodly has a relative high cpu load, and I can noticed the mouse move lag. I even can not play a movie ( very slow).

After swtich to a previous version driver: , ( the installation steps same),
this driver does not include nvidia-modeset process, and
mouse move quickly and movie play smoothly