WARNING: GPU:0: Unable to read EDID for display device VGA-0

I’m getting this

WARNING: GPU:0: Unable to read EDID for display device VGA-0

error with kernel parameter: nvidia-drm.modeset=1

~ ls /sys/class/drm
card0  card0-HDMI-A-1  card0-VGA-2  card1  card1-LVDS-1  card1-VGA-1  renderD128  renderD129  version

I tried to disable device with video=VGA-2:d and it didn’t show error until OS loaded.

~ xrandr -q

outputs VGA-0 is connected when it’s not. Disabling and ignoring with xorg.conf didn’t help.

Section "Monitor"
    Identifier "VGA-0"
    Option "Ignore" "true"
    Option "Enable" "false"
EndSection

Driver Version: 390.48
Kernel: 4.15.0-36-generic

It’s a known issue with some bioses. The option
Option “IgnoreDisplayDevices” “CRT”
put into the screen or the device section of your xorg.conf should help, though a bug with that was observed before in a recent driver. Please check.

Sorry for delay, but your suggestion did not work for me. I’m still getting this error when session is locked and also on login screen. As I know, gpu-manager controls my xorg configs.

I’m using proprietary driver. Driver Version: 390.77

/var/log/gpu-manager.log

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.15.0-43-generic/updates/dkms
Found nvidia module: nvidia-drm.ko
Looking for amdgpu modules in /lib/modules/4.15.0-43-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:116
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:df5
BusID "PCI:1@0:0:0"
Is boot vga? no
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Found "/dev/dri/card1", driven by "i915"
output 0:
	card1-LVDS-1
Number of connected outputs for /dev/dri/card1: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
Intel IGP detected
Intel hybrid system
Creating /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
Setting power control to "on" in /sys/bus/pci/devices/0000:01:00.0/power/control

/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

# DO NOT EDIT. AUTOMATICALLY GENERATED BY gpu-manager

Section "OutputClass"
    Identifier "Nvidia Prime"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "IgnoreDisplayDevices" "CRT"
    Option "PrimaryGPU" "Yes"
    ModulePath "/x86_64-linux-gnu/nvidia/xorg"
EndSection

Please check if

xrandr --output VGA-0 --off

works for you.

Not working.

$ xrandr --output VGA-0 --off
warning: output VGA-0 not found; ignoring

I already disabled it in xorg.conf

/usr/share/X11/xorg.conf.d/80-disablevga.conf

Section "Monitor"
    Identifier "VGA-0"
    Option "Ignore" "true"
    Option "Enable" "false"
EndSection
$ xrandr -q
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 544mm x 303mm
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
LVDS-1-1 connected (normal left inverted right x axis y axis)
   1366x768      60.01 +
   1360x768      59.80    59.96  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
VGA-1-1 disconnected (normal left inverted right x axis y axis)
  1024x768 (0x4c) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x5b) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x6a) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1 video=VGA-2:d"

I can’t see LUKS encryption password enter screen on my external monitor too. I think it’s something with driver because when I tried nouveau driver I could see password screen on external monitor. Forcing mode with kernel mode setting did not help.

I have the same problem for long time. The videocard remembers and persistently calls 2nd VGA monitor that was switched off years ago.

I have posted some notes on this here https://ask.fedoraproject.org/en/question/114297/how-to-make-nvidia-driver-forget-an-unplugged-display/