driver installation failure

Hi

My laptop has Ubuntu Desktop 10.10 and has kernel 2.6.25-23-generic. It uses ATI X1600 as primary video card and it has a GTX 460 connected to it through an ExpressCard slot.

Under Windows 7 everything runs fine. The GTX 460 is used as secondary card and does my compute work only(CUDA runs normally). But due to my special set up, everytime before I boot into Win7 I have to do a PCI set up script first.

But in Ubuntu, while both ATI X1600 and GTX 460 are correctly identified by lspci, my driver installation fails. At the end of the nvidia-installer.log, it says that my card on 10de:0e22 (the PCI ID of GTX 460, I don’t remember if the device ID is shown in the log or not) installed on the system is not compatible with the driver. Is it that the driver can only be installed for the primary graphics card?

I found something here:http://www.nvidia.com/object/linux-display-ia32-260.19.44-driver.html
Note that the list of supported GPU products is provided to indicate which GPUs are supported by a particular driver version. Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available.

Why do I have to disable my primary card? Why on Windows 7 I don’t have to do that?

Another question: if I disable my primary card and boot without gdm, will my laptop monitor still display the terminal? Or will it be altogether shifted to the output of the GTX 460? I don’t have an external monitor or adapter to transfer the output back to my internal monitor! :pinch:

Sounds like the driver is outdated. Can you check you are trying with the newest driver available?

I tried 270.29 (I ran the command: sudo apt-get update && sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings, so I did not use the download from Nvidia website)

Well the kernel nvidia is found in /lib/modules/2.6.35-22-generic/kernel/drivers/video/nvidia (yeah I moved back to 2.6.35-22)

Under text mode, when I run lspci -k there is no kerneo module currently in use for my GTX460

when I run the command startx, with the /etc/X11/xorg.conf provided by the nvidia-config utility, xserver fails to start and it reports that it cannot find the nvidia kernel. Though it still prompts me to check kern.log

So I checked kern.log, and here’s the relevant result:

Basically the driver is successfully installed. It just refuses to work with my device. Anyone has any solutions/experience with this?

All I want is just to run CUDA on it… not sure if GLX is needed