Dual monitor on Jetpack TX1 R28.2


I’d like to make my TX1 video output to 2 monitors simultaneously,
one is HDMI on SOR1
the other is eDP on SOR0.

Refer to the discussion in forum (https://devtalk.nvidia.com/default/topic/1023387/jetson-tx1/how-to-make-a-kernel-with-dual-diplay-on-r28-1/post/5217743/#5217743 ),
my TX1’s eDP outputs individually well so far,
but when the HDMI cable is attached,
the eDP video disappears then monitor says “no signal”.

in the above condition,
Once the HDMI cable is detached, the eDP video comes back normally.

BTW, from my log (nominal clock), it seems TX1’s eDP uses its internal EDID, but TX1 does fetch the monitor’s name correctly.
How to check this?

Pls help .

cold-boot-edp-only.log (65.1 KB)
attaching_HDMI_cable.log (18 KB)


According to the log, it seems eDP should turn on in the end. Doesn’t it?

[   99.635841] dp lt: switching from state 2 (clock recovery) to state 3 (channel equalization)
[   99.635849] dp lt: state 3 (channel equalization), hpd 1, pending_lt_evt 0
[   99.640711] dp lt: CE done
[b][   99.640712] dp lt: switching from state 3 (channel equalization) to state 5 (link training pass)
[   99.640721] dp_audio switch 1
[   99.839212] tegradc tegradc.0: unblank[/b]
[   99.843346] tegradc tegradc.1: blank - powerdown
[   99.893754] tegradc tegradc.1: unblank
[   99.895765] tegradc tegradc.1: nominal-pclk:148500000 parent:148500000 div:1.0 pclk:148500000 147015000~161865000
[   99.896601] tegradc tegradc.1: hdmi: pclk:148500K, set prod-setting:prod_c_hdmi_75m_150m
[   99.936229] tegradc tegradc.1: unblank

Refer to the log, the eDP content should be displayed.

In fact, there’s nothing on my eDP monitor. (I connect the output ports to 2 monitors (HDMI and eDP) individually).


I will help check that.


I cannot hit this issue. May I ask how you configure your eDP and HDMI?

Does single monitor hit any issue? (Single HDMI,eDP)

Hi Wayne:

My original modification are in several DTSs according the labels.
now I put them into the same DTS,
“Dual monitor” works now.

Thanks for your attention.