eDP issue in TX2

Hello,

Does anyone know how to enable the eDP function in TX2?
We can enable the eDP by using the solution in:
https://devtalk.nvidia.com/default/topic/964977/jetson-tx1/enable-edp-on-tegradc-0-with-sor/post/5167347/#5167347

But it does not work in TX2.
I use the tegra186-quill-p3310-1000-a00-00-edp.dtb,
and modify the kernel/t18x/drivers/video/tegra/dc/nvdisp/nvdisp_stub.c
in the tegra_primary_panel_get_dt_node() function,
I assign a panel “panel-s-edp-uhdtv-15-6” as default,
but nothing show in the eDP & HDMI panel.
Would someone give me some suggestion?
Thanks a lot.

Hi IsaHung,

Did you sync the kernel source of jetpack3.1? We have a dts for auo-edp panel now.

kernel-dts/tegra186-quill-p3310-1000-c00-00-auo-1080p-edp.dts

Hi IsaHung,

Do you resolve your problem?

Hello Wayne,

NO. It cannot work.
And For TX1 R28.1, the original solution in:
https://devtalk.nvidia.com/default/topic/964977/jetson-tx1/enable-edp-on-tegradc-0-with-sor/post/5167347/#5167347
does not work too.
Do you have any patch for the eDP?
Thanks a lot.

Could you share your kernel message by using dmesg?

(Please note dmesg may be too long to directly paste on forum)

Hello Wayne,

After I change another one eDP panel, the eDP works now.
But I had another issue about the dtb file.
If I modify the /boot/extlinux/extlinux.conf and adding: FDT /boot/tegra186-quill-p3310-1000-c00-00-auo-1080p-edp.dtb
The original eth0 in ifconfig will be disappeared.
But if I grep the igb driver,
it’s mounted by kernel.
nvidia@tegra-ubuntu:~$ dmesg | grep igb
[ 3.028829] igb: Intel® Gigabit Ethernet Network Driver - version 5.3.0-k
[ 3.028831] igb: Copyright © 2007-2014 Intel Corporation.
Do you know how to fix it?
Thanks a lot.

Hi IsaHung,

Please note that the correct way to update a dtb file is not modiyfing extlinux.conf.

Reference for you:
http://elinux.org/Jetson/TX2_DTB

IsaHung,

May I ask do you use gnome on your system?

Hello Wayne,

I use the default Ubuntu and do not use the gnome.
The dtb for eDP and NIC is OK.
Thank you very much!

Good to know that~!