eeepc-wmi error - 430.14 installation failed - Unable to load the 'nvidia-drm' - Centos 7

Hello,

I’ve read similar threads posted here, but haven’t been able to resolve the issue yet.

Setup: CentOS 7.6.1810, GTX 1080 ti, (gcc 9.10), Attempting to install version 430.14

Upon completion of driver installation and receiving the “Unable to load the ‘nvidia-drm’” message, I also saw the following output:

eeepc-wmi: probe of eeepc-wmi failed with error -5

I’ll attach the nvidia-bug-report.log, any help will be greatly appreciated.

Thank you!

nvidia-bug-report.log.gz (87.1 KB)
nvidia-installer.log (9.13 KB)

Nouveau is active so the nvidia driver can’t load. Please uninstall the .run installer using the --uninstall option, then add a repository:
https://rpmfusion.org/Configuration/
and install the driver:
https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla

Thank you Generix.

I might have messed things up earlier, by generating the bug report only after rebooting into an environment with Nouveau active… My flow was:

  1. I disabled Nouveau in grub cfg, rebooted into GUI (low res), switched to text mode, installed driver (with failure)
  2. Re-enabled Nouveau in grub cfg, rebooted into GUI
  3. Generated the bug report and submitted
    …So, I guess I completely tainted the report? sorry.

In any case, I just executed as per your input above: uninstalled 430.14 -> configured -> installed the driver.
After rebooting, it appears that nvidia driver is not present, and now I do not have Nouveau running either.
(i.e. nvidia-smi produces: “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver”).
(i.e.2 lshw -class display produces: no “driver” keyword on the line: “configuratoin: latency=0”)

Any further advice will be great (i.e. or how should I produce some relevant logs in this case?)

Thank you.

Ok, with that info, I’ve taken another look at your logs and you simply have secure boot enabled, so the nvidia driver can’t be loaded since it isn’t signed. Just disable secure boot in bios.

Generix, Thank you for the rapid replies!

OK,

  • I removed the xorg-x11-drv-nvidia* and kmod-nvidia*
  • Updated BIOS (great input!!)
  • Installed 430.14… and it completed installation without errors :-)

So, original post has been answered… (thank you very much!!!).

BUT, current situation is unclear to me. After reboot, I see the centos splash screen for about 2 seconds (high res, indicating nvidia running? Nouveau is definitely disabled in grub). Then, before the login dialog appears, the graphic is gone, and all I see is text mode - log of the boot sequence (i’ll try to send a screenshot if required, I’m writing this from a second PC).
The sequence terminal window occupies the entire screen (in high res, btw). There is no ‘$’ or ‘#’ prompt… nothing can be done here, it’s stuck.
When I switch to virtual terminal 2, by pressing ALT-F2, I can login as regular… inquiring here if nvidia running by nvidia-smi, produces the: “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver” message.

If you suspect this might have been cause due to some tangling between the two different nvidia drivers, I can install the OS from scratch and try fresh - just let me know if you recommend it.

Thanks again!

Did you disable secure boot in bios after upgrading?
You can check for it using

sudo dmesg |grep secure

Otherwise, please create a new nvidia-bug-report.log and attach.
Uploading from text console:

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

The issue was indeed the bios secure boot.
Once properly disabled, everything runs perfect now, using 430.14.
I really appreciate all your help - Thank you very much!!
Cheers!