Emulator Failed to Start


server: HP SL250s Gen8 [BIOS P75]
CPU: 2x E5-2670 v1
GPU: Nvidia Grid K2
Host OS: XenServer 7.0.0 Enterprise
Guest OS: Windows 10 Exterprise Edition
vGPU Profile: K220Q

vdi001, vdi002, vdi003, vdi005, vdi006, vdi007

The above won’t start unless the VM is set to NONE for the vGPU. It shows the following error:

An emulator required to run this VM failed to start

If 2 VM’s are set to NONE for the vGPU and 1 is running then it shows the following error when trying to start the 2nd VM:

Internal error: xenopsd internal error:Unix.Unix_error(Unix.ENOSPC,"write","")

I currently have 3 other VM’s on this server running as NONE for the vGPU so I know I can have more than 1 running with NONE set. I have 4 VM’s running with the K220Q profile on a Grid K2 card [allows for 16 VM’s running this profile on a single K2 card]. Yesterday I had 10 running with the K220Q profile and teh other 3 running with NONE. That worked fine then it crapped out today and I haven’t been able to recover it yet.

I thought perhaps it may be a driver issue. I reverted vdi007 to a snapshot from yesterday and that did not change the behavior. I deleted vdi007 and created a new one from the master snapshot image that all of the VM’s were created from and that did not change anything.

I shutdown vdi008 [running the K220Q profile] and tried to start vdi007 again but get the same emulator error. vdi008 will not start now either and shows the emulator error.

Thread locked as is a duplicate: