Dell PE R720 with GRID K1 and XenServer 7.0 - VMs not powering on with error "an emulator requi

On Dell PE R720 with two NVIDIA GRID K1 cards and a fresh install of XenServer 7.0 Any VM with a virtual GPU assigned (doesn’t matter which vgpu profile) to it would not power on. Would get an error message of “an emulator required to run this vm failed to start”. If I unassign a virtual GPU from the VM, the VM would power on, and boot like normal. Everything worked fine with XenServer 6.5 using virtual GPUs

To fix this, I updated the Dell PE R720 BIOS to 2.5.4 from 2.5.2. VMs now power on, and fully boot up.

Hope this helps anyone else with this issue.

Hi Rick,

Thank you so much for taking the time to drop by from twitter - really appreciated and hope the forum bank of goodwill helps you out in the future - good karma <3

Rachel

Thanks Rick, we’ve contacted Citrix and Dell teams to and asked them to be aware and published this. The benefits of having a GPU support team :-D

http://nvidia.custhelp.com/app/answers/detail/a_id/4163

Saw the same on Cisco B200 M4 - though it was related to ECC: When activated in the BIOS on the server, the VM’s with GPU attached would state the same error as above. As soon as we deactivated ECC again, the VM’s would boot normally.

Don’t know if the BIOS-update you mention may have reset the ECC-setting?

Is there a further fix for when the BIOS is already updated to 2.5.4? Same config as OP here, except only x1 K1 per host. No VM with a vGPU assigned will start. Error of ‘an emulator required to run this vm failed to start’