Enabling and display with HDMI on Custom Carrier Boards

Hi everyone,

I want to enable HDMI on Custom Carrier Boards , I foun it‘s not working follow this steps:

======================================
Enabling HDMI on Custom Carrier Boards

This information is specific for modifying the device tree file for your custom carrier board and does not apply when you use the Developer Kit carrier board.

  1. Download the example HDMI DTS file

    Download the 鈥渢egra234-dcb-p3701-0000-a02-p3737-0000-a01_hdmi.dtsi鈥� file from Jetson Linux 34.1.1 | NVIDIA Developer

  2. Modify kernel dts with HDMI connector support

    The JetPack5.0-DP release Kernel sources includes a dtsi file that sets DCB with DP connector support by default. Users will need to update the provided dtsi file with the downloaded dtsi file to enable HDMI setting.

    Path: <Kernel_Sources>/hardware/nvidia/platform/t23x/concord/kernel-dts/

  3. Modify your board dts to replace the default DCB dtsi:

— a/tegra234-p3701-0000-p3737-0000.dts
+++ b/tegra234-p3701-0000-p3737-0000.dts
@@ -17,7 +17,7 @@
#include “cvm/tegra234-p3701-0000.dtsi”
#include “cvb/tegra234-p3737-0000-a00.dtsi”
#include “tegra234-power-tree-p3701-0000-p3737-0000.dtsi”
-#include “tegra234-dcb-p3701-0000-a02-p3737-0000-a01.dtsi”
+#include “tegra234-dcb-p3701-0000-a02-p3737-0000-a01_hdmi.dtsi”
#include <tegra234-soc/mods-simple-bus.dtsi>
#include “cvb/tegra234-p3737-camera-modules.dtsi”
Recompile the Kernel by completing instructions in Kernel Customization .

  1. Reflash your board with the updated Kernel and Kernel DTB

5、set HDMI ports GPIO7_5V0_HDMI_EN is high ,like this



6、reboot ,No display on the display screen.
Are there any other parts of the device tree that need to be modified?

Did you remember to add hotplug gpio according to your hardware design?

--- a/hardware/nvidia/platform/t23x/concord/kernel-dts/tegra234-p3701-0000-p3737-0000.dts
+++ b/hardware/nvidia/platform/t23x/concord/kernel-dts/tegra234-p3701-0000-p3737-0000.dts
@@ -34,6 +34,7 @@
        compatible = "nvidia,p3737-0000+p3701-0000", "nvidia,tegra234", "nvidia,tegra23x";
 
        display@13800000 {
+               os_gpio_hotplug_a = <&tegra_main_gpio TEGRA234_MAIN_GPIO(M, 0) GPIO_ACTIVE_HIGH>;
                status = "okay";
        };

Please change M0 to your gpio in use.

Hello,Do I need to set M0 as an input pin or an output pin?
My schematic has HPD set to active low logic, contrary to the reference design, what changes do my drivers need to make?

Then set the GPIO_ACTIVE_HIGH to GPIO_ACTIVE_LOW.

Hi WayneWWW,
I have set PM.00 to GPIO_ACTIVE_LOW , the system up,no display on the display screen. But during startup with”boot options’’ steps is ok about display.





What is the monitor you are using now?

Currently the Orin HDMI driver is not yet ready and only support to 2K.

Also, could you share the “lsmod” on your side?

nvidia@nvidia:~$ lsmod
Module Size Used by
fuse 118784 5
nvidia_modeset 1077248 3
mttcan 65536 0
can_dev 32768 1 mttcan
can_raw 28672 0
can 28672 1 can_raw
lzo_rle 16384 144
lzo_compress 16384 1 lzo_rle
zram 32768 12
aes_ce_blk 36864 0
crypto_simd 24576 1 aes_ce_blk
cryptd 24576 1 crypto_simd
aes_ce_cipher 20480 1 aes_ce_blk
ghash_ce 28672 0
snd_soc_tegra186_asrc 36864 1
loop 36864 1
snd_hda_codec_hdmi 57344 1
snd_soc_tegra210_ope 28672 1
snd_soc_tegra186_dspk 20480 2
snd_soc_tegra210_adsp 753664 1
sha2_ce 20480 0
snd_soc_tegra210_mvc 20480 2
snd_soc_tegra186_arad 24576 2 snd_soc_tegra186_asrc
snd_soc_tegra210_afc 20480 6
snd_soc_tegra210_dmic 20480 4
snd_soc_tegra210_adx 28672 4
ucsi_ccg 28672 0
sha256_arm64 28672 1 sha2_ce
snd_soc_tegra210_iqc 16384 0
snd_soc_tegra210_admaif 118784 1
ofpart 16384 0
snd_hda_tegra 20480 0
snd_soc_tegra210_amx 28672 4
snd_soc_tegra210_mixer 45056 1
snd_soc_tegra210_i2s 24576 6
snd_soc_tegra210_sfc 57344 4
cmdlinepart 16384 0
snd_soc_tegra_machine_driver 16384 0
nvadsp 106496 1 snd_soc_tegra210_adsp
sha1_ce 20480 0
typec_ucsi 32768 1 ucsi_ccg
snd_soc_tegra_pcm 16384 1 snd_soc_tegra210_admaif
snd_soc_tegra_utils 24576 3 snd_soc_tegra210_admaif,snd_soc_tegra_machine_driver,snd_soc_tegra210_adsp
snd_hda_codec 118784 2 snd_hda_codec_hdmi,snd_hda_tegra
snd_soc_tegra210_ahub 1228800 3 snd_soc_tegra210_ope,snd_soc_tegra210_sfc
qspi_mtd 28672 0
typec 40960 1 typec_ucsi
snd_soc_simple_card_utils 24576 1 snd_soc_tegra_utils
snd_hda_core 81920 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_tegra
snd_soc_spdif_tx 16384 0
tegra210_adma 28672 4 snd_soc_tegra210_admaif,snd_soc_tegra210_adsp
pwm_fan 24576 0
tegra_bpmp_thermal 16384 0
nct1008 24576 0
mtd 69632 4 cmdlinepart,qspi_mtd,ofpart
userspace_alert 16384 0
nvidia 1519616 7 nvidia_modeset
spi_tegra114 32768 0
binfmt_misc 24576 1
nvgpu 2461696 16
ina3221 24576 0
ip_tables 36864 0
x_tables 49152 1 ip_tables

… Honestly, this photo does not help at all.

Please share me the xrandr result…

like this:
nvidia@nvidia:~$ xrandr
Screen 0: minimum 8 x 8, current 3440 x 1440, maximum 32767 x 32767
DP-0 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 797mm x 334mm
3440x1440 59.97*+ 99.98
2560x1080 143.94 119.88 59.94 50.00
1920x1080 60.00 59.94 50.00
1720x1440 59.94
1680x1050 59.95
1440x900 59.89
1280x1024 75.02 60.02
1280x720 60.00 59.94 50.00
1024x768 99.97 75.03 70.07 60.00
800x600 99.66 75.00 72.19 60.32 56.25
720x576 50.00
720x480 59.94
640x480 99.77 75.00 72.81 59.94 59.93
DP-1 disconnected (normal left inverted right x axis y axis)

You are running in 3440x1440, which may not be supported. Please try with 1920x1080p first.

Hi WayneWWW,
Setting the Resolution of the display with 1920x1080p, It’s not working. Is there anything else I should pay attention to this issue.

Follow the debug method I posted here. And share the log in txt file.

Also, hotplug the cable and see if dmesg got anything printed. This is to validate hotplug can work or not.

1 Like

Hi WayneWWW,
It is failed to rmmod nvidia-modeset and nvidia. I can’t find anything about hotplug. Debug logs like this:
orin_HDMI_Display fail.txt (75.0 KB)

please use lsof to check which process is using those modules. Kill those processes and then rmmod again.

Hi WayneWWW,

I have rmmod the modules(nvidia-modeset \ nvidia) ,and insmod them . But hdmi display is not Ok !
orin_hdmi_displayfail220607.txt (99.6 KB)

Of course not OK. This is just to dump log…

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

So where is the log after you insmod…? You didn’t show the most important part at all…