Custom board, hdmi display not showing


I Have a Jetson Orin AGX connected to a custom board which is currently booting correctly, i can access the jetson via debug terminal on uart3 debug line. I have followed the display adaptation guide to change from DP to HDMI and edited the dcb blob using dcb tool.

Here is the current configuration :

Also updated the the pinmux using the excel sheet (and generated the dtsi files).

Here is the dmesg :
dmesg.log (174.4 KB)

Here are the hardware schematics :

Please let me know what to do to fix it!

Thank you!



D51/D52 shall connect to D2+/-. Are you sure the wiring is correct?


D51/D52 are transmitter lines TX0 (see screenshot) so it should connect to transmitter lines 0 of hdmi connector, right? From datasheet of HDMI connector, it seems to be correctly connected.

What did i miss?

Thank you!



We have resoldered correctly the pins (so TX2 on 699 pins connector is connected to TX0 of hdmi connector, same for TX0/TX2)

Yet the display still doesnt show…

please share the xorg.0.log here.

Xorg.0.log (14.7 KB)


[ 23.078] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 23.078] (–) NVIDIA(GPU-0): DFP-0: Internal TMDS
[ 23.078] (–) NVIDIA(GPU-0): DFP-0: 165.0 MHz maximum pixel clock
[ 23.078] (–) NVIDIA(GPU-0):
[ 23.079] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 23.079] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 23.079] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 23.079] (–) NVIDIA(GPU-0):
[ 27.052] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 27.052] (–) NVIDIA(GPU-0): DFP-0: Internal TMDS
[ 27.052] (–) NVIDIA(GPU-0): DFP-0: 165.0 MHz maximum pixel clock
[ 27.052] (–) NVIDIA(GPU-0):
[ 27.054] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 27.054] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 27.054] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 27.054] (–) NVIDIA(GPU-0):

This log shows HDMI connection is not detected. Looks like the hotplug related pin is not added.

You could also check this post which is doing similar thing as your case.

I added the hotplug inside dtb, by adding it inside the source file and rebuilding the kernel :
IN Linux_for_Tegra/source/public/hardware/nvidia/platform/t23x/concord/kernel-dts/tegra234-p3701-0000-p3737-0000.dts

display@13800000 {
os_gpio_hotplug_a = <&tegra_main_gpio TEGRA234_MAIN_GPIO(M, 0) GPIO_ACTIVE_HIGH>;
status = “okay”;

Then i flashed completly the jetson.

Still no display, here is the Xorg.0.log
Xorg.0.log (14.3 KB)

I feel like i missed the gpio part, but i dont know how to add it using the pinmux spreadsheet

I can try to add it manually but i feel like its not the proper way.


Always make sure your device tree is the one that got flashed to the board by reading your flash log.

Your flash log will tell you which dtb to use. Not me.

Hi! Thanks for your quick answer!

I feel like I was’nt clear or that i dont understand correctly but what i tried to say is that im using the gpio pin as hotplug (pin K50) in my dtb (
temp.dts (528.9 KB)) so i think that i need to add the pin to the gpio.dtsi file generated from the spreadsheet like this

Is that correct? If so, how can i reach this configuration using the pinmux spreadsheet?



You can directly put it to your device tree dtsi file. No need to use spreadsheet to generate.


Unfortunatly, it did not work but i think the Xorg.0.log is different now. Here it is
Xorg.0.log (14.1 KB)

What should i do?

Xorg log is still same.

Your right, im sorry.

Just some questions

Do you or your team have ability to check below things?

  1. The device tree flashed to the board is correct or not

  2. The pinmux file flashed to the board is correct or not

  3. The content of a device tree blob is correct or not

I can share all 3 of those if you want. Ill reply when i get all of it

No, I mean are you able to check or not. I don’t have time to check these things to you if you saw how many topics are out there.

I can only teach you how to check, but not able to read each line in your file.

I get it.

The device tree should be correct, i followed the topics you shared and added the os_gpio_hotplug_a line to the display@13800000. The content of the device tree blob are correct following this topic HDMI Output cannnot work in AGX Orin based CustomBoard 35.3.1 - #4 by WayneWWW. It has been modified by the blob modifier tool. And finally the pinmux file is adjusted to make sure it follows the developper guide (Welcome — Jetson Linux<br/>Developer Guide 34.1 documentation).

How did you update these things to your board? That is the point that I asked those 3 questions.

You can have 100 versions of binary on your host side, but if none of them flashed to your board, then it would be in vain too.

There is another thorough post which includes almost every check.

Sorry that some posts are in Chinese due to customer is from China.