Enabling APE sound card driver for i2s support on CVB with devkit module


We designed a custom board for Jetson orin agx devkit module and modified the configuration to be able to make it work. However, the jetson does not deem to have the drivers for APE sound card :

gaus@tegra-ubuntu:~$ cat /proc/asound/cards
 0 [HDA            ]: tegra-hda - NVIDIA Jetson AGX Orin HDA
                      NVIDIA Jetson AGX Orin HDA at 0x3518000 irq 112

It’s pretty much a duplicate of this issue : Enabling APE sound card for I2S support · OE4T/meta-tegra · Discussion #1254 · GitHub.

Part of the fix is to download the missing driver when building the kernels :

…so adding kernel-modules to your build would be a good start.

I tried donwloading the kernels with git command (source_sync.sh) instead of public sources but it did not work. How can I compile the kernels with the needed drivers?



Here is my dmesg output :
dmesg.txt (65.6 KB)

Still no APE sound card…

Also, I tried flashing default configuration BSP on devkit board and it did have the APE sound card. So my guess is that the driver are installed but not loaded.

Hi Loic,

Please confirm are you able to compile the drivers and is it module build?

If yes, please share the output of command lsmod. It will help to understand what all modules are loaded.


I tested with fresh BSP on devkit board (downloaded from Jetson Linux 35.3.1 | NVIDIA Developer) and the alsa drivers would load. So it must be something stopping the drivers from initializing.

Here is the output of lsmod:
lsmod.txt (2.5 KB)
dmesg.txt (66.0 KB)

If you need more information, let me know!



Any updates on what could stop the drivers from initializing? I’m thinking it could be hardware, but I cant find anything that could stop the drivers from detecting the sound card.

Could it be about the i2c lines? Because they are all connected to unused camera module :

About this, we have come to realise there is no audio codec on our CVB. The I2s Lines are directly connected to jetson.

Also, there is no section about this type of error in the troubleshooting section of the l4t guide.

Thanks for your help,



I’m closing topic since I now have the tegra-asoc error displayed inside the online guide Audio Setup and Development — Jetson Linux Developer Guide documentation.

Basically, what I did is remove the i2c node inside aconnect node in device tree (all commented inside the file):
tegra234-p3737-audio.dtsi (8.2 KB)

So now what i need to do is find a way to configure the ahub with I2S DAI links, its written in the doc, but I might have to create another topic.

Loic Boileau