Enabling I2S4 pinmux slows EMC clock to 204MHz

After maxing everything out with jetson_clocks, I enabled I2S4 using:

sudo /opt/nvidia/jetson-io/config-by-function.py -o dtb i2s4

After rebooting, nothing we do will set the EMC clock back to 1600MHz. We’ve tried running jetson_clocks and the override flag will be set to 1, but the EMC clock will still be 204MHz

We’ve tried to override the frequency with the following commands but jetson_clock shows the same thing.

$ echo <emc_freq> > /sys/kernel/debug/clk/override.emc/clk_update_rate

$ echo 1 > /sys/kernel/debug/clk/override.emc/clk_state

Any ideas? Thanks!

What’s your BSP version?
I got below error.

root@nvidia-desktop:/opt/nvidia/jetson-io# ./config-by-function.py -o dtb i2s4
Traceback (most recent call last):
  File "./config-by-function.py", line 184, in <module>
  File "./config-by-function.py", line 167, in main
    dtbo = configure_jetson(jetson, args.out, header, funcs[idx])
  File "./config-by-function.py", line 81, in configure_jetson
    % (function, header))
NameError: Function i2s4 is not supported on Jetson Nano CSI Connector!

$ head -1 /etc/nv_tegra_release

R32 (release), REVISION: 6.1, GCID: 27863751, BOARD: t210ref, EABI: aarch64, DATE: Mon Jul 26 19:20:30 UTC 2021

I’ve also used jetson-io.py to configure the pinmux. That also slowed the EMC clock, but they both configured i2s4 without errors.

I’m using an image that was originally l4t 4.0 that I updated to 4.6. When I used dtc to compare the device trees from before and after I enabled i2s4, it used the old device tree as a baseline and then added the new configuration to that. The new device tree had a build date older than the device tree I had before I enabled i2s4 anyway.

I tried flashing an SD card with the latest Jetson Nano image and enabling i2s4 and the EMC clock stayed at the high rate. It didn’t seem to enable i2s4 when I tried copying a dtb a generated from the latest image to my working image and updating the extlinux.conf.