Enabling SPI using jetson-io messes with the display resolution

I am using the jetson nano 4gb-devkit variant, Jetpack 4.6.3 and I have followed this tutorial Compiling Custom Kernel Modules on the Jetson Nano | Kevin's Blog to enable spi dev as a permanent part instead of module and in the last step I create the image using the -b board parameter as jetson-nano-2gb-devkit. Everything works fine, the image boots correctly. Now I proceed to configure the spi pins using jetson-io. I followed this tutorial https://jetsonhacks.com/2020/05/04/spi-on-jetson-using-jetson-io/, as my jetson-io doesnt work I do the fixes he suggests. and after configuring I reboot the system and all the resolution and UI is messed up

This is in my dtb when display works fine but jteson-io does not work. Following the jetson haks link When I place tegra210-p3448-0000-p3449-0000-a02.dtb in dtb folder the jetson-io starts working and I configure the pins. and it save the pins in tegra210-p3448-0000-p3449-0000-a02-user-custom.dtb…Now when i restart the jetson nano the display is all messed up. If I delete this newly created dtb and restarts the jetson. the display starts working correctly.

Just a guide.

p3448-0003 is jetson nano 2gb.

p3448-0000 and p3448-0002 are all for jetson nano 4gb. So you should never use that dtb (xxx-p3448-0000-xxx.dtb) for your jetson nano 2gb.

I am using jetson nano 4gb devkit,
How can I compile the image manually for Jetson nano 4gb?
what optiob should I chose from the ./tools/jetson-disk-image-creator.sh for my jetson nano 4gb and how will jetson-io work on jetson-nano 4gb devkit

You could check the *.conf in your Linux_for_Tegra.

There is one jetson-nano-devkit.conf. That one is for 4GB to use.

The parameter is not some kind of magic string. They are basically just the prefix of those xxx.conf file name.

Can I use that with the jetson-disk-image-creator.sh ?

I have tried but I showed the following output.

Please use the “jetson-nano” string.

Thanks for the prompt replies. I have tested your suggestion and IT WORKS!!! i have configured the spi through jetson-io. I am leaving for home as its already late night here. will test the function of spi early tomorrow morning and accept your solution if that worked…

Sorry for the late reply, I was busy testing. The display resolution is resolved but SPI is not working, It worked for the first time and then I reboot the system and its not working after that. I shorted the MISO and MOSI (19,21) in my case and ran the spi_test script. I received the sent data on MISO but when I restarted the jetson I am unable to receive anything on MISO. same scprit doesnt work. There is nothing that changed in the configuration, just rebooted the nano.

I confirmed that my jetson has spi0.0 available in /dev, my pins are configured in /opt/nvidia/jetson-io/jetson-io.

Can you guide me what has gone wrong after the reboot that it stopped working.

Basically what we are doing in this topic is use jetson-io to configure the pinmux.

The rest of work is not related to pinmux. Please file a new topic for your question in spi.

Sure, I will open a new Issue in few moments. please look into that. You have been of great help. Thanks. I am accepting your previous answer for pinmux and hdmi issue

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.