End Goal: Use CUDA - Issues with GUI after installing NVIDIA driver - Laptop model: MSI GS65 Stealth Thin 8RF

Hi,

I’m having an issue with GUI after installing NVIDIA driver. Running Nvidia-smi gives me an output that the driver is installed but it doesn’t look like it’s functioning properly. I’m not able to go to GUI.

The OS is RHEL 7.4. I have also tried RHEL 7.6 but it results in the same issue. The computer model is MSI GS65 Stealth Thin 8RF(brand new laptop) and it is a new setup. I’ve tried NVIDIA driver 418.56. I cannot update chipset drivers as the OS is RedHat. BIOS is the latest version “ E16Q2IMS.111 ”.

I don’t think I can disable onboard Intel graphics via BIOS (no option available for this model). The end goal is to use Nvidia GPU for Machine Learning and have GUI at the same time.

NVIDIA-SMI output:

±----------------------------------------------------------------------------+
| NVIDIA-SMI 418.56 Driver Version: 418.56 CUDA Version: 10.1 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 107… Off | 00000000:01:00.0 Off | N/A |
| N/A 50C P0 30W / N/A | 0MiB / 8119MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

KDE graphical.target in not working but multi-user.target does work. I have installed NVIDIA driver from official NVIDIA website - it did not work. Specifically nvidia-smi command stated that the driver is installed but when I ran nvidia-settings command it gave me this error “The control display is undefined; please run 'nvidia-settings --help” for usage information. I have also tried installing rpm NVIDIA drivers - https://rpmfusion.org/Howto/NVIDIA but that did not work either. Can you please point me in the right direction?

Thanks
Lovish

Use the repo drivers, then try setting it up to use PRIME:
https://github.com/wildtruc/nvidia-prime-select
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910