Error changing power model: NVPM ERROR: Failed to exec option requests!

So I went through the documentation to customize the config in order to add a module to the kernel. I built my image, all seemed well, until I started encountering some issues and tried to switch the power model. Now I get:

$ sudo nvpmodel 1
[sudo] password for adminuser: 
NVPM ERROR: BUG: unhandled option combination optMask = 0x0!
NVPM ERROR: Failed to exec option requests!

Any idea what might be causing this?

Hi mdegans,

We’re trying to reproduce this issue, the status will be updated soon, please stay tuned.


I think I may have figured it out. I updated JetPack, applied binaries, but forgot to rebuild the kernel or the modules before i ran the image creation script. My kernel folder looked like:

[user@host] -- [~/Dev/nano/jetpack/Linux_for_Tegra/kernel] 
 $ ls -l
total 62816
drwxr-xr-x 2 user group     4096 Mar 13 00:45 dtb
-rwxr-xr-x 1 user group   856213 Mar 13 00:45 dtc
-rw-r--r-- 1 user group 34048008 Mar 13 00:45 Image
-rw-r--r-- 1 user group 17893905 Mar 13 00:46 kernel_headers.tbz2
-rw-r--r-- 1 user group 11466907 Mar 13 00:46 kernel_supplements.tbz2
-rw-r--r-- 1 user group    18385 Mar 13 00:45 LICENSE
-rw-r--r-- 1 user group    17992 Mar 13 00:45 LICENSE.dtc
-rwxr-xr-x 1 user group     3443 Mar 13 00:45

That was sily of me. I think it’s using the stock kernel…

uname -a

Linux fixed-nano 4.9.140-tegra #1 SMP PREEMPT Wed Mar 13 00:32:22 PDT 2019 aarch64 aarch64 aarch64 GNU/Linux

Yup. As to why it’s not working with the stock kernel and modules… idk. I’m going to make another image tomorrow with an actual custom kernel :) and see if it works.

Any update ??

I didn’t get a chance on Friday and have been away from my Nano this weekend. I will try to get around to it on Monday.

Does Nvidia provide a Ubuntu Docker image with all the Jet Pack stuff preinstalled? Because that would make repeated image builds a lot simpler and if I automate these sorts of steps I tend to make fewer silly mistakes.

Wayne, I have a few comments on this page.

Where the emphasized command is supposed to be run is never specified. Somebody following these instructions has to know to run them from the kernel sources root and where that is which is also not specified (that I can find).

Re: this is confusing as well.


Suggestion: can source_sync default to the lastest tag as that would solve both problems?

Right now the kernel is building on my workstation. I’m going to get coffee.

Edit: building is done. archived modules, applied binaries, ran sudo ./ -o tester.img -s 8G -r 200

… and now writing that to a sd card.


So it’s doing it even with a custom kernel.

[username@hostname] -- [~] 
 $ ssh someuser@newtestnano
ssh: Could not resolve hostname newtestnano: Name or service not known
[username@hostname] -- [~] 
 $ ssh someuser@newtestnano
The authenticity of host 'newtestnano (' can't be established.
ECDSA key fingerprint is SHA256:gZAg7Rwas9XSAaNcGWI6Vlm8TW1S6Lqlo0F0k9r1f64.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'newtestnano,' (ECDSA) to the list of known hosts.
someuser@newtestnano's password: 
Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.9.140+ aarch64)

 * Documentation:
 * Management:
 * Support:
This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

To restore this content, you can run the 'unminimize' command.

15 packages can be updated.
0 updates are security updates.

Failed to connect to Check your Internet connection or proxy settings

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

someuser@newtestnano:~$ nvpmodel 1
NVPM ERROR: BUG: unhandled option combination optMask = 0x0!
NVPM ERROR: Failed to exec option requests!
someuser@newtestnano:~$ sudo nvpmodel 1
[sudo] password for someuser: 
NVPM ERROR: BUG: unhandled option combination optMask = 0x0!
NVPM ERROR: Failed to exec option requests!
someuser@newtestnano:~$ uname -a
Linux newtestnano 4.9.140+ #2 SMP PREEMPT Mon Jun 17 11:43:48 PDT 2019 aarch64 aarch64 aarch64 GNU/Linux
someuser@newtestnano:~$ lsmod
Module                  Size  Used by
fuse                  119563  1
bnep                   19270  0
btusb                  44635  0
btrtl                   7877  1 btusb
btbcm                  10207  1 btusb
btintel                13635  1 btusb
nvs                    62167  0
nvgpu                1705637  3
bluedroid_pm           16187  0
ip_tables              21421  0
x_tables               38080  1 ip_tables

You probably want to try :

sudo nvpmodel <b>-m </b>1

That worked. Thank you so much! This page has the wrong command (or is there an argument parsing issue in the new version?).