Error libcudart : cannot open shared object file: No such file or directory

I’m installing Caffe on a CentOS 7.3 system over which I do not have any administrative privileges.
I just have a folder under my name in the home directory to work on it.
The system already have 2 versions of cuda installed on it 7.5 and 9.0
And they have given the path of each of them in the document file.

When I attempt to install caffe with runtest, I encounter the following message:

error while loading shared libraries: libcudart.so.9.0: cannot open shared object file: No such file or directory

I already putted the path of cuda 9.0 in the makefile.config but dont know why this error is shown. I changed the path to the cuda 7.5 still the same error.
So when I googled I found out that even the cuda is installed we need to add the the path to the environment variable as many people solved it by this way(can be seen here:https://github.com/BVLC/caffe/issues/4944)

The problem here that I cannot do this as I am not the root.
Please is there any way to solve this ?
Thanks in advance

This is a problem that occurs at runtime, not at compile-time.

You need to set the LD_LIBRARY_PATH variable correctly to point to the CUDA 9.0 installation.

Thank you for your reply but as I can see in the end I cannot set the environmental variable LD_LIBRARY_PATH as I am not a root user.

You can set it. You need to learn more about linux.

thank you so much with some research I was able to figure it out. I thought that I will not be able to found the bashrc under my home directory and it was just hidden.
Again I faced a new error with

CUDA driver version is insufficient for CUDA runtime version
I tapped nvidia-smi
but I got nothing as an output
and with nvcc --version I got
-bash-4.2$ nvcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2017 NVIDIA Corporation
Built on Fri_Sep__1_21:08:03_CDT_2017
Cuda compilation tools, release 9.0, V9.0.176

-bash-4.2$ lspci | grep -i
08:00.0 3D controller: NVIDIA Corporation GT200GL [Tesla C1060 / M1060] (rev a1)
0a:00.0 3D controller: NVIDIA Corporation GT200GL [Tesla C1060 / M1060] (rev a1)
11:00.0 VGA compatible controller: Silicon Motion, Inc. SM750 (rev a1)

so what’s the problem here? The cuda driver is it installed or not!

Tesla C1060 is not supported by any recent NVIDIA GPU driver or toolkits. Your GPUs are too old. I would suggest that you stop using them and use some recent GPU hardware.

I just got an access to clustered cloud server so that I can train my data on it.
I looked into the nvidia drivers and I found out that the last driver can be download for tesla C1060 is 340.93 with cuda 6.5.
So here my questions does installing this driver with cuda 6.5 will solve the problem or not?
and I just want to know if cuda can be installed in a choosen folder instead of the default usr/local?

If you install a 340.xx driver and CUDA 6.5, you should be able to get CUDA (6.5) functional on your Tesla C1060, assuming there are no other issues.

That won’t be a suitable setup for Caffe, Tensorflow, or anything that uses CUDNN.

None of those things work with a GPU that is that old. That GPU has a compute capability of 1.3. You need a compute capability of 3.0 or later for any modern software to work such as anything you would use for Deep Learning Training.

You won’t be able to install a 340.xx driver without root privilege. It would be necessary/mandatory to get the C1060 working at all.

You can install CUDA (not the driver) in any directory you choose. That does not require root privilege, but it requires that you have write access to the directory where you would like to install it.

I don’t plan to provide any further suggestions about how to use the C1060. I don’t recommend it. If you wish to use it, use the search skills you’ve already demonstrated to answer your questions about it. None of your questions are new or unique.

The questions were asked on purpose not because I dont know but to show them this topic as a reference so that they will change it as they refused my request before.
Thank you it was a clear answer as I wanted :)