Error: missing dtbfile

hello liuzhiyuan0821,

actually, this is developer preview release and it’ll deprecate soon.

Hi, when I use SDK manager, there are two versions of 5.0.2, one is 5.0.2 runtime and the other is 5.0.2. Which one should I use. In addition, I would like to ask if I want to change the kernel later and burn the changed kernel to Orin using USB. Is there a detailed burning process document. I’ve been looking for it on the forum for a long time. Maybe I can’t find it. thank you

I use 5.0.1 because I am worried that the new version of 5.0.2 is unstable, so I want to use the version of 5.0.1

hello liuzhiyuan0821,

you may select JetPack 5.0.2.
please check /boot/extlinux/extlinux.conf, there’s LINUX entry to specify kernel, you may update the binary file to apply your kernel image.
JetPack 5.0.2 is production release, ideally, it’s more reliable than JetPack 5.0.1 developer preview release.

HI,I used version 5.0.2 for burning. I used source_ Sync.sh download the source code and burn it through flash. Then it will still have the first error.

hello liuzhiyuan0821,

there are some bugs to fetch kernel sources via source_ sync.sh directly.
please see-also Topic 224160,
please update the script file to sync the source again. you may also use the attach nvbuild.sh to compile the sources.
thanks

Yes, I saw this topic. I changed the source according to the post_ Sync.sh file, but the above error will still occur. But I didn’t manage the nvbuild.sh file

I obtained the kernel code according to the steps in the following page;
https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/Kernel/KernelCustomization.html
I want to ask the steps in this page:

  1. Replace Linux_for_Tegra/rootfs/usr/lib/modules/$(uname r)/kernel/drivers/gpu/nvgpu/nvgpu.ko with a copy of this file:
    $kernel_out/drivers/gpu/nvgpu/nvgpu.ko
  2. For the device tree, replace the files in Linux_for_Tegra/kernel/dtb/ with a copy from:
    $kernel_out/arch/arm64/boot/dts/nvidia/
  3. Replace Linux_for_Tegra/kernel/Image with a copy of this file:
    $kernel_out/arch/arm64/boot/Image
    Hello, where is the location of the file I need to replace? When I replace the jetpack I downloaded using the SDK Manager_ 5.0.2_ Linux_ JETSON_ AGX_ ORIN_ Target directory, and then use the command sudo. / flash SH Jetson AgX Orin devkit mmcblk0p1 can be burned successfully. However, when I burn, I cannot open the DP screen, but the startup progress can be displayed on the DP screen. thank you

hello liuzhiyuan0821,

you don’t need to re-flash the target since it’s loadable kernel module, and Orin is able to read kernel and device tree via file system.
please review /boot/extlinux/extlinux.conf, you should update LINUX and FDT entry for loading your customize binaries.

Hi, I don’t need to load my custom kernel module. I just want to download the source code and then write flash through flash script. But I don’t know where there are detailed steps. In this page Kernel Customization — Jetson Linux<br/>Developer Guide 34.1 documentation I only saw how to download the source code. I finished building the kernel: in the following steps
Replace Linux_ for_ Tegra/rootfs/usr/lib/modules/$(uname -r)/kernel/drivers/gpu/nvgpu/nvgpu. ko with a copy of this file:
$kernel_ out/drivers/gpu/nvgpu/nvgpu.ko
For the device tree, replace the files in Linux_ for_ Tegra/kernel/dtb/ with a copy from:
$kernel_ out/arch/arm64/boot/dts/nvidia/
Replace Linux_ for_ Tegra/kernel/Image with a copy of this file:
$kernel_ out/arch/arm64/boot/Image
I want to know the Linux here_ for_ Where do Tegra / rootfs / usr / lib / modules / $(uname - R) / kernel / Drivers / GPU / nvgpu / nvgpu.ko come from? Can you tell me the detailed steps

hello liuzhiyuan0821,

sorry, I do not fully understand your question.
may I know what’s your use-case? you may also check r35.1 developer guide, Flashing Script Usage.

Hi, I can brush Orin through SDK manager, but there is another method, sudo. / flash SH jetson-agx-orin-devkit mmcblk0p1, I want to know what the steps of this flash method are, so I found this page and unzipped tar - XJF public according to the steps in the page_ sources. Tbz2, but Linux in step 5, 6 and 7 of the steps to build the kernel on this page_ for_ Tegra / rootfs / usr / lib / modules / $(uname - R) / kernel / Drivers / GPU / nvgpu / nvgpu.ko where is the address of this directory

hello liuzhiyuan0821,

you’ve already download JetPack release image with SDKManager, right?
then, the path is looking like below…
~/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/rootfs/usr/lib/modules/5.10.104-tegra/kernel/drivers/gpu/nvgpu/

hi,I have completely mastered burning images and components through SDK or flash. Now I want to make an image. I know that I use flash Sh-k-g-app, but I don’t know what the specific steps are. Can you tell me? Or give me a reference document. thank you

hello liuzhiyuan0821,

did you meant image cloning?

please refer to developer guide for Flashing Script Usage.
the sample command is… $ sudo ./flash.sh -r -k APP -G <clone> <board> mmcblk0p1
thanks

Hi, I use sudo. / flash on the first Orin sh -r -k APP -G system. Img Jetson AgX Orin devkit mmcblk0p1 cloned my image, which generated two files, one is system.img and the other is system.img raw。 When I use the command sudo CP system IMG bootloader / system.img to the second Orin is to use the new system IMG burns and finds that the second Orin is different from the first image. I tried sudo CP system.img again raw bootloader/system. img。 The same result was obtained. I followed the steps exactly. Can you give me some suggestions? Thank you

hello liuzhiyuan0821,

please have -r option applied if you would like to re-flash the target with your back-up image,
this -r command will reuse the existing system.img for image flashing.

Hi, I used the first Orin to create system.img and system.img.raw. I used system.img and system.img.raw to cover the second system.img .Then I tried three instructions to burn. These three instructions are sudo. / flash sh jetson-agx-orin-devkit mmcblk0p1; sudo ./flash. sh -r jetson-agx-orin-devkit mmcblk0p1; sudo ./flash. sh -r -k app Jetson AgX Orin devkit mmcblk0p1. I got the same result, which is different from the first Orin

hello liuzhiyuan0821,

once you ran this, your original back-up image has gone. it’ll generate a new system.img.

Hello, I use sudo ./flash.sh -r Jetson AgX Orin devkit mmcblk0p1 is burned. The burning is unsuccessful. The error message is as follows:
[ 432.8828 ] Writing partition recovery-dtb with tegra234-p3701-0000-p3737-0000.dtb.rec [ 392792 bytes ]
[ 432.8859 ] […] 100%
[ 432.8990 ] Writing partition esp with esp.img [ 67108864 bytes ]
[ 432.9029 ] […] 100%
[ 434.9032 ] Writing partition APP with system.img [ 17465668740 bytes ]
Error: Return value 3 ] 000%
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.