Error on initialize graphic driver. NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!

On some tx2 system, I encountered this error dialog saying “The system is running in low-graphics mode”.
And I found this error log in Xorg.0.log. It seems like there’s an error on a graphic output device.

...
[    18.643]  Module class: X.Org Server Extension
[    18.643] (II) NVIDIA GLX Module  28.2.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-773)  Thu May 17 00:15:24 PDT 2018
[    18.643] (II) LoadModule: "nvidia"
[    18.644] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    18.644] (II) Module nvidia: vendor="NVIDIA Corporation"
[    18.644]  compiled for 4.0.2, module version = 1.0.0
[    18.644]  Module class: X.Org Video Driver
[    18.644] (II) NVIDIA dlloader X Driver  28.2.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-773)  Thu May 17 00:16:09 PDT 2018
[    18.644] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    18.645] (WW) Falling back to old probe method for NVIDIA
[    18.645] (II) Loading sub module "fb"
[    18.645] (II) LoadModule: "fb"
[    18.645] (II) Loading /usr/lib/xorg/modules/libfb.so
[    18.645] (II) Module fb: vendor="X.Org Foundation"
[    18.645]  compiled for 1.18.4, module version = 1.0.0
[    18.645]  ABI class: X.Org ANSI C Emulation, version 0.4
[    18.645] (II) Loading sub module "wfb"
[    18.645] (II) LoadModule: "wfb"
[    18.645] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    18.645] (II) Module wfb: vendor="X.Org Foundation"
[    18.645]  compiled for 1.18.4, module version = 1.0.0
[    18.645]  ABI class: X.Org ANSI C Emulation, version 0.4
[    18.646] (II) Loading sub module "ramdac"
[    18.646] (II) LoadModule: "ramdac"
[    18.646] (II) Module "ramdac" already built-in
[    18.646] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    18.646] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    18.646] (==) NVIDIA(0): RGB weight 888
[    18.646] (==) NVIDIA(0): Default visual is TrueColor
[    18.646] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    18.646] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration" "true"
[    18.647] (**) NVIDIA(0): Option "MetaModes" "800x480 +0+0"
[    18.647] (**) NVIDIA(0): Enabling 2D acceleration
[    18.647] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    18.647] (EE) NVIDIA(0): Failing initialization of X screen 0
[    18.647] (II) UnloadModule: "nvidia"
[    18.647] (II) UnloadSubModule: "wfb"
[    18.647] (II) UnloadSubModule: "fb"
[    18.647] (EE) Screen(s) found, but none have a usable configuration.
[    18.647] (EE)
Fatal server error:
[    18.647] (EE) no screens found(EE)
[    18.647] (EE)
...

I use auvidea J120 and HDMI output. with this xorg.conf

Section "Module"
    Disable     "dri"
    SubSection  "extmod"
        Option  "omit xfree86-dga"
    EndSubSection
EndSection

Section "Device"
    Identifier  "Tegra0"
    Driver      "nvidia"
# Allow X server to be started even if no display devices are connected.
    Option      "AllowEmptyInitialConfiguration" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    ModeLine       "800x480"      29.40    800  816  878  982    480  482  488  528 -hsync +vsync
    HorizSync       31.0 - 76.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Tegra0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "MetaModes" "800x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Can somebody help me?

We don’t suggest such way for Tegra dispaly.
The graphic driver on tegra only accepts the mode from display edid.

To clarify for the benefit of future readers, the default /etc/X11/xorg.conf from JetPack does not have the Monitor or Screen sections given above. It does have the Module and Device sections. If you got this error, you could try removing the Monitor and Screen sections.

1 Like