Error when trying to run Hello AI world

So I was going through the jetson nano create you own image recognition program(python) and i double and triple checked my code, but I got this error

“import-im6.q16: not authorized argparse' @ error/constitute.c/WriteImage/1037. ./my-recognition.py: line 8: syntax error near unexpected token (’
./my-recognition.py: line 8: `parser = argparse.ArgumentParser()’”

when I tried to test the program om one of the examples using “./my-recognition.py polar_bear.jpg”

can anyone assist me?

thanks
James
EE(in training)

Hi,

It looks like you are facing a similar issue of this topic.
Would you mind to apply the answer and try it again?
https://stackoverflow.com/questions/55558605/import-im6-q16-not-authorized-error-os-error-constitue-c-writeimage-1037-fo/55570825

Thanks.

That didnt seem to fix it for me, im still getting the same error

What’s the first line in your script?

Ok no sorry it did work but now im getting a different error its saying I dont have a module named Jetson

in the import jetson.inference line
I downloaded and built the entire inference project just as the hello ai world said to so im not sure why im now getting this error

My first 6 lines of code are
"#!/usr/bin/env python3

import jetson.inference
import jetson.utils
import argparse"

It says the error is on line 3

“ModuleNotFoundError: No module named ‘jetson’”

thanks for any help
James
EE(in training)

Looks like jetson-inference isn’t installed for python3. You can either try changing your first line to python instead of python3 or doing a “sudo apt install python3-dev” and then re-building (and re-installing) jetson-inference. Then the error should go away.

that worked

thanks