Error while flashing JetPack-L4T-2.3.1 to a brand new TX1 (tegradevflash return 3)

Hi,

I am facing this error while flashing JetPack-L4T-2.3.1 to a brand new TX1?

Error: Return value 3
Command tegradevflash --pt flash.bin --storageinfo storage_info.bin --create
Failed flashing t210ref.

It has been discussed here:

https://devtalk.nvidia.com/default/topic/967747/-flash-problem-command-tegradevflash-error-return-value-3/

disk space does not seems be be a problem here. On host, my home partition has 25G and root partition has 4.8G free space.

ls -lh ./64_TX1/Linux_for_Tegra_64_tx1/bootloader/system.img.raw

-rw-r–r-- 1 root root 14G Dec 28 18:33 ./64_TX1/Linux_for_Tegra_64_tx1/bootloader/system.img.raw

flash_os_64_tx1.log is attached.

flash_os_64_tx1.log (153 KB)

Probably most of the 25GB would be used for flash if it runs from the home partition (though likely it would work); in the case of flashing from the 4.8GB the partition would be maxed out and no space would be left on the host before system.img is ever created.

The log looks like everything worked until the root partition was being written. I would expect that at least some percentage completion had made it in before fail, but the log shows all “000%”. Had there been a permissions issue, then the sparse image would not have been created in the first place, so the script has permission to read the file. I would have to conclude that it was the transmission that failed, or the Jetson refused to accept the data.

Are you using a VM host? If so, I would highly suspect the USB (under a VM it is common to see USB work for part of the install and then stop working). If not, then it is a mystery, though perhaps there is a hardware error in the Jetson.

Have you tried flashing more than once?

I tried twice but result was the same. I am using native Ubuntu 14.04 on host. No VM

Then on third try I copied the following folders from my home directory to a separate partition with >100G free space

  • jetpack_download
  • JetPack-L4T-2.3.1-linux-x64.run

I run the installer as root from the new location. It completed successfully. Not sure if it is due to bigger host partition or due to running as root.

Thanks.

So far as I know JetPack runs as non-root, but would use sudo for things requiring root (I can’t confirm that). Running the driver package flash.sh script (which JetPack does) requires root privileges to work correctly (it may appear to work at times without root privilege, but would actually not function correctly). There is a possibility that the larger partition helped if something was truncating during run on a smaller partition (25GB is cutting it close).