Issue when flash JetPack to TX2

After I run “./JetPack-L4T-3.1-linux-x64.run” and choose “Device access internet via router/swith” on my Virtual Machine, then I got the following error informations:

[1.2495]BootRom is not running
[2.2943]
[2.2952]tegradevflash_v2 --isapplet
[2032.8166]
[2032.8964]tegradevflash_v2 --iscpubl <- freezes at this command for almost 6 hours…
[2032.8973]CPU Bootloader is not running on device.
[3048.6245]
[61720.7302]Retrieving board information
[61720.7338]tegrarcm_v2 --oem platformdetails chip chi…
[61720.7361]Applet is not running on device. Continue …
[62735.5379]
[62735.5449]tegradevflash_v2 --oem platformdetails…
[62735.5504]CPU Bootloader is not running on device.
[63751.3451]
Error: Return value 4
Command tegradevflash_v2 --oem platformdetails chip chip…
Fail flashing t186ref.
0
Failed to flash device.

And I also tried this methods:
https://devtalk.nvidia.com/default/topic/1002081/jetson-tx2/jetpack-3-0-install-with-a-vm/
by doing this, I got error message on my TX2: not enough space left…

Is there anyone got the same problem and already solved with some methods? Can you share some tips? Please!!

Thanks!!

VMs normally fail. Regarding not enough space on device, the entire file system size is created on the host, plus a sparse version. So if you create a 30GB partition for the Jetson, then you will require about 30GB spare on the host just for that one file…other files probably consume another 5GB. From the location of the JetPack flash do you have space left from “df -H -T .”?

As linuxdev alluded to, flashing from Virtual Machine is not officially supported.
Please try flashing JetPack from a native Ubuntu 16.04 x86_64 host PC (dual boot ok).

Hi dusty_nv,
Thank you! Now I am trying to use native ubuntu on windows 10 and run the command “./JetPack-L4T-3.1-lonux-x64.run”, it can only Uncompressing JetPack, and did nothing else… do you know how should I do for next step?
Thanks!

If windows is running it is still in a VM and USB will be a problem. If you dual boot, then Ubuntu is native since only Ubuntu or only Windows will run at one time. Also be sure networking is set up and for example no firewall is in the way.

I was able to install via an Ubuntu VM. The trick was to change from USB 3.0 to USB 2.0 mode.