JetPack 2.3.1 Flash problems

I wanted to get the latest dev environment on my Jetson TX1 so I decided to follow the instructions on the Nvidia website. I followed the installation process in this link https://developer.nvidia.com/embedded/jetpack.

  1. My host computer is a Ubuntu Virtual Machine 14.04 x64 with GUI interface, It runs on a MacBook Pro.

  2. I checked the USB ports when the Jetson is on flash mode by lsusb it recognizes that Jetson is connected.

  3. The first time I tried to install the jetpack, the process worked for a while then it hung with this message on the terminal:

applet not running on device.Continue with Bootloader.

I closed the terminal and repeated the installation process. It worked for a bit and then it produced the the following message.

BootRom is not Running

applet not running on device.Continue with Bootloader.

Also the jetpack files are no longer copied to the Jetson device. When I check the USB connection with lsusb I can see Jetson is connected. Can someone help me with this? I maybe overlooked a step or not doing something right.

One thing to beware of is that if you do any operation on a recovery mode Jetson is that you have to restart the recovery mode if anything is interrupted. For example, it does not seem to work correctly to clone two partitions in a row without restart. In your case did you try to flash or run something in recovery mode twice without restarting the recovery mode?

As far as I know VM installs have a lot of problems. Many of them fail for strange reasons, sometimes USB just doesn’t work right part way through. The screenshot indicates that USB had started out working, but something is failing part way into the flash process…this seems to be a repeating theme for VM installs.

@linuxdev

I tried to follow the installation instructions to be best of my abilities. Everytime I flashed the device, I made sure to restart the Jetson and turn on the recovery mode.

I prefer using native box as supposed to VM but I only have access to my laptop and I have to start developing on Jetson so I have no choice.

In another nvidia post @dusty_nv suggested to delete one the sub folders in the installation pack, I tried that and it didn’t work so I deleted all the JetPack files and downloaded it again, let’s see how much it helps if I do the installation process again.

Sometimes delete/re-install of flash files helps. I simply don’t know enough about VM setup to help much on that, but those people who did succeed after similar problems typically made some adjustment to the USB (perhaps there is a buffer size or other adjustment your VM allows). Should you be forced to use the VM I would very closely study any way to provide increased USB resources to the VM. Also beware that you need a lot of disk space…if not the image getting flashed will be truncated (I think your failure was too early on to have image truncation considered, but if you get past the stall issue then this will matter).

Thanks for your input, I will look up the USB resources on my VM, I have set it to a filter which only accepts Jetson i.e. on recovery mode Nvidia Corp . Maybe I can increase the USB buffer. My VM has 40GB, I think that should be enough but I will increase it so I don’t have problems later on. The packages are still downloading, it’s such a long process :(

During flash an image the size of the eMMC disk is created…the root partition will be about 15GB all by itself. A compressed version is then created, somewhere between 2GB and 3GB. Temporary files may be created while compressing. Whatever space is occupied after downloading and unpacking either JetPack or command line, be sure to have about 25GB spare before starting flash.

In terms of buffer, there may be adjustable amounts of RAM you can reserve for USB buffering…I don’t know what to look for in VM setup, but on a Linux kernel there are some parameters that can be passed to the USB drivers to allocate more buffer…somewhere is possibly a similar setting for the host to the VM. Theory being that more buffer implies a better tolerance to data underruns/overruns.

I also had trouble flashing Jetpack 2.3.1 from my VirtualBox machine and got stuck at the same spot you did (“BootRom is not running”). I had no trouble with Jetpack 2.3, however. After reading this post I changed the amount of RAM given to the VM from around 2GB to around 6GB and that seems to have done the trick.