Need help installing Jetpack on Jetson TX2 with VM, no access to native ubuntu machine

Aloha Everyone,

Thank you for taking the time to read my post. I am on a senior college project that gets passed down to the next group every year. This year we are having trouble with the Jetson TX2 that the last year previously had.

We are currently trying to install the Jetpack applications with the current Nvidia SDK Manager using VirtualBox and Ubuntu 18.04, but the flashing gets stuck at 99%. The last thing the console says is “BootRom is not Running”.

We use the USB that the Jetson comes with.
The Jetson and Host are on the same network.
We’ve tried using different versions of Jetpack.
*I may be missing some information, but I will update the post as the ideas arise.

Some of the things we’ve tried are:

Please let me know if you need any more information from me. Also, please keep in mind, I am very much a beginner with all of this, so I may need help with getting information for you.

On an unrelated note, we have the e-con Systems camera HEXCUTX1 base on the Jetson rather than the provided 5 MIPI CSI Camera that the Jetson came with. I found that the Jetson will not boot if the provided camera is on the board, but will boot with the e-con Systems base. I am unsure if this may be the problem with the Jetpack installation.

Hi suyatd,

I can’t answer this due to officially flashing Jetson devices from VM is not supported, but you may refer to below topic to see if can help:

While this is no more supported than the other, it is VERY doable to use a Raspberry PI 3 or 4 using RaspberryOS (Latest builds from the Pi Foundation…) in 32-bit mode and using User-mode QEMU to flash a command line tegraflash image set.

Have done this to solve a problem at work.

If you’re good with taking the command line tools solution to load the image, you should give it consideration if you’ve got one in hand.

Hi svartalf,

So we actually have a Raspberry PI 3, thankfully. We are attempting this as I type this message. As we try to figure this out, what is User-mode QEMU? Is there a tutorial I should follow? Thank you very much.

Hi kayccc,

So I’ve tried the vagrant method and it was very close to flashing, but I am not sure what happened, but it has failed.

Another problem has arise, however. The Jetson TX2 is not stuck in recovery mode. The “./” method detects the board in recovery mode, but it fails to recover. It gets stuck at “tegradevflash_v2 --iscpubl” Any possible solution to this? Thank you very much for your support.

Have you forced the VM to handle that USB at all times? The usual problem with a VM is that USB repeatedly disconnects and reconnects during a flash, but the VM does not pick up the reconnect (the parent o/s is getting in the way). Unless the Jetson reboots it will remain in recovery mode…most likely it is the VM’s fault for not knowing this. One thing you could attempt is to unplug and replug the micro-B USB when this happens (without stopping the flash program).

Oh, I see. That’s what they showed in this video here. How to flash Jetson Tx2 Using Vagrant and VirtualBox - YouTube

I’ve done this method shown in that video, but for some reason, the Jetson is stuck in recovery mode now. Any thoughts on this? Thank you very much for the response.

Getting stuck is a sign of a VM. Sometimes it can be something else, but this is very typical of a VM. I hate to say it, but you will probably have to study the VM configuration and find a way to keep the parent o/s from getting in the way of USB.