Set the Jetson TX2 to Factory setting

Hello everyone,

I’m completely new to Jetson world. I got Jetson TX2 from the university to do a research project using it (real time object detection using Jetson TX2). I powered the Jetson TX2 in order to start installing Jetpack. It displayed the Linux desktop with Nvidia account. I noticed that there might have been some prior students who worked on it before. So is there way i can set the Linux on the Jetson TX2 to Factory mode so that everything was downloaded from others will be deleted and i get eventually the Ubuntu as it came from Nvidia.

Would appreciate your help

Khaled
Master-student

Just do an ordinary flash of the most recent release. FYI, JetPack/SDK Manager is a front end to the flash software, and is also a front end to adding the extra content (e.g., CUDA). You can find the list of releases here:
https://developer.nvidia.com/embedded/jetpack-archive

See if your login works at that URL, the SDKM will use that name/pass to log in to download files during the flash. Make sure you have an HDMI monitor and keyboard attached to the Jetson (flash will complete, and then newer releases will have you create your account on first boot of the TX2…only then can extra package install continue).

The software runs on an Ubuntu PC, the Jetson is put in recovery mode, and the communications is through the micro-B USB cable (try to use the one which comes with the dev kit…it has the NVIDIA green on the connector…others typically are for charging and fail if put under stress).

Thank you for your support. I will try it. Just one question so that i understand what i’m doing. What do you mean by flashing , to install the jetpack ( thus i need a host pc and a target)?, or flashing means to install the latest release of Ubuntu on the Jetson ?

i would appreciate your support

Khaled

Flashing means you install JetPack/SDK Manager to the host PC, and then the host PC can flash the Jetson after connecting the micro-B USB cable (the Jetson would need to be in recovery mode before this would work). The host PC needs to be running Ubuntu, and the result will be the Jetson running the flashed version of Ubuntu. You might see this referred to as “Linux for Tegra” (“L4T”), but this is just the stock Ubuntu with the NVIDIA-specific hardware drivers added.

“Target” is just the Jetson. JetPack/SDKM works with several Jetson models, of which any can be a target.

Note that the Ubuntu mechanism to do version upgrades will render the Jetson unusable until flashed again (not to be confused with package updates…those should be done).

Thank you very much for your explanation. I just have one problem in i believe you can help me with:

I have been trying the whole day flashing the Jetson TX2 but it doesn’t work so far. I did the following steps:

1- I have the the Host PC (Ubuntu 16.04 on virtual machine)
2- the Target (Jetson TX2)
3- Target is connected with Host using mini USB as described.

Both Target and host are hocked up to through Ethernet to LAN

So when it comes to flashing i set the Jetson to Recovery mode and then click on START FLASHING. For the first 15 to 10% works but then the usb connection is lost and it returns with the following Error:

Cannot detect device. make sure the host sees the Target by typing : lsusb in the command line.

I’ve looked up a similar problem tin the forum and found some answers like i must install python but it is already installed.

I tried also the automatic flashing but no work.
I would really appreciate to get some suggestions as I’ve started to lose some hair on this thing.

Thanks in advance
Khaled
Student Trainee

This is a known issue for VMs. USB itself is categorized as “hot plug” because USB can be disconnected and reconnected and the host will query the USB and “do the right thing”. However, the VM isn’t really the host…the parent o/s to the VM is the host. If the parent VM does not send 100% ownership to the VM (even when disconnecting and reconnecting), then the VM will fail. Some people get this to work with extra setup of the VM, but others give up and use an actual Linux install. I couldn’t tell you what the setup details are for your particular VM, but you’d have to figure out how to keep the parent o/s from touching the USB.

Thank you so much for your Info. I’ve actually switched from Virtual box to VMWare and it finally works.

So anyone who wants to Flash the Jetson, SAVE TIME AND DO IT USING VMware

Thx
Khaled