Error while pulling container tao-toolkit:5.0.0-tf1.15.5

Please provide the following information when requesting support.

• Hardware (T4/V100/Xavier/Nano/etc)
• Network Type (Detectnet_v2/Faster_rcnn/Yolo_v4/LPRnet/Mask_rcnn/Classification/etc)
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here)
• Training spec file(If have, please share here)
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)

I’m trying to use the jupyter notebook to train and test detectnetv2.
When I execute the cell with the code to convert the dataset format:

Creating a new directory for the output tfrecords dump.

print(“Converting Tfrecords for kitti trainval dataset”)
!mkdir -p $LOCAL_DATA_DIR/tfrecords && rm -rf $LOCAL_DATA_DIR/tfrecords/*
!tao model detectnet_v2 dataset_convert -d $SPECS_DIR/detectnet_v2_tfrecords_kitti_trainval.txt -o $DATA_DOWNLOAD_DIR/tfrecords/kitti_trainval/kitti_trainval

I get this error:

Converting Tfrecords for kitti trainval dataset
2024-02-29 10:38:35,771 [TAO Toolkit] [INFO] root 160: Registry: [‘’]
2024-02-29 10:38:35,814 [TAO Toolkit] [INFO] nvidia_tao_cli.components.instance_handler.local_instance 360: Running command in container:
2024-02-29 10:38:35,818 [TAO Toolkit] [INFO] nvidia_tao_cli.components.docker_handler.docker_handler 322: The required docker doesn’t exist locally/the manifest has changed. Pulling a new docker.
2024-02-29 10:38:35,818 [TAO Toolkit] [INFO] nvidia_tao_cli.components.docker_handler.docker_handler 173: Pulling the required container. This may take several minutes if you’re doing this for the first time. Please wait here.

Pulling from repository:
Docker pull failed. 500 Server Error: Internal Server Error (“Head “”: unauthorized: authentication required”)

I don’t know how to fix this

Could you please
$docker login

I already have, but that doesn’t fix the issue :(
I logged in on the terminal before starting the jupyter notebook and then tried it again within the notebook on a cell right before atempting the conversion; but the error remains the same

Could you please open a terminal to pull the
$ docker pull

I get the error:
Error response from daemon: Head “”: unauthorized: authentication required

I openned the terminal, succesfully logged in with $ docker login
And then did $ docker pull

Can you share the result of
$ cat /root/.docker/config.json

Yes, here it is:

“auths”: {”: {
“auth”: “JG9hdXRodG9rZW46bnZhcGktUmxlNlBpYy1raGhKMDNhUmQ2NlFRSHhTNlAtLTlTMUlwRFh3UjBsd0dJb3JNQ25lQ0xJLTBvMEdwMmNWUS0zeQ==”

If you are under root, please check /root/.docker/config.json.
If not the root user, please check xxx/.docker/config.json.

More, to narrow down, please try to logout and login again.
$ docker logout
$ docker login

Also, you can try to check if you can pull any image under TAO Toolkit | NVIDIA NGC.

It got solved by loging out and using a new API Key, thank you very much!
I have a question: What is the difference between API key and a Personal key? It says that both can be used for NGC catalog as well as other stuff, but it wasn’t working with the personal key

Glad to know it is working now!

What is Personal key?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.